Bug 697434 - texvc binary missing and deal link in package mediawiki-math-1.16.2-56.fc14.x86_64
Summary: texvc binary missing and deal link in package mediawiki-math-1.16.2-56.fc14.x...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawiki
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-18 09:20 UTC by schlaffi
Modified: 2011-04-30 23:25 UTC (History)
1 user (show)

Fixed In Version: mediawiki-1.16.4-58.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-26 16:04:11 UTC


Attachments (Terms of Use)

Description schlaffi 2011-04-18 09:20:02 UTC
Description of problem:
/usr/lib64/mediawiki/math/texvc is missing, although /usr/share/mediawiki/math/texvc symlinks it

Version-Release number of selected component (if applicable):
mediawiki-math-1.16.2-56.fc14.x86_64

How reproducible:
Always

Steps to Reproduce:
# yum install mediawiki-math-1.16.2-56.fc14.x86_64
# readlink /usr/share/mediawiki/math/texvc
/usr/lib64/mediawiki/math/texvc
# file /usr/lib64/mediawiki/math/texvc
  
Actual results:
/usr/lib64/mediawiki/math/texvc: cannot open `/usr/lib64/mediawiki/math/texvc' (No such file or directory)


Expected results:
/usr/lib64/mediawiki/math/texvc: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, stripped

Additional info:
-This bug was just introduced by the recent update.
-Using the source code at /usr/share/... it i no problem to compile texvc
-Some 3rd party tools might require texvc and expect it at either location

Comment 1 Axel Thimm 2011-04-22 08:07:38 UTC
Thanks for reporting!

In the specfike I was moving texvc to an arch dependent location (libdir) and was keeping a symlink in the arch independent one (datadir). But I accientially next remove the libdir instead of the datadir contents in the specfile. :/

It was easy to fix (one line) and will soon be available in koji (watch this bug for the proper URLs), as well as a proper update (but that takes some time).

Comment 2 Fedora Update System 2011-04-22 08:36:05 UTC
mediawiki-1.16.4-58.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mediawiki-1.16.4-58.fc14

Comment 3 Fedora Update System 2011-04-22 08:36:54 UTC
mediawiki-1.16.4-58.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mediawiki-1.16.4-58.fc13

Comment 4 Fedora Update System 2011-04-22 08:37:38 UTC
mediawiki-1.16.4-58.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mediawiki-1.16.4-58.fc15

Comment 5 Fedora Update System 2011-04-22 21:18:23 UTC
Package mediawiki-1.16.4-58.fc13:
* should fix your issue,
* was pushed to the Fedora 13 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mediawiki-1.16.4-58.fc13'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mediawiki-1.16.4-58.fc13
then log in and leave karma (feedback).

Comment 6 schlaffi 2011-04-23 08:53:10 UTC
The testing package (mediawiki-1.16.4-58.fc14.x86_64) works for me. thanks!

Comment 7 Fedora Update System 2011-04-26 16:03:29 UTC
mediawiki-1.16.4-58.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-04-30 23:23:03 UTC
mediawiki-1.16.4-58.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-04-30 23:24:51 UTC
mediawiki-1.16.4-58.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.