Bug 697472 - python returing negative values
python returing negative values
Status: CLOSED DUPLICATE of bug 697470
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python (Show other bugs)
All Linux
high Severity high
: rc
: ---
Assigned To: Dave Malcolm
BaseOS QE - Apps
Depends On:
  Show dependency treegraph
Reported: 2011-04-18 08:11 EDT by Zbysek MRAZ
Modified: 2013-07-03 09:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-04-18 08:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Simple python test script (121 bytes, text/plain)
2011-04-18 08:11 EDT, Zbysek MRAZ
no flags Details

  None (edit)
Description Zbysek MRAZ 2011-04-18 08:11:31 EDT
Created attachment 492866 [details]
Simple python test script

Description of problem:
when testing bug #628730 found out, that s-c-u is not able to delete homedir of user with hude UID due to python os.lstat() returning negative values for owner and/or group.

Simple python testing script attached

Version-Release number of selected component (if applicable):

How reproducible:
On 32bit arch. The others are working correctly.

Steps to Reproduce:
1. run the script with file/dir parameter owned by huge UID/GID user.
Actual results:

Expected results:

Additional info:
This is not regression against RHEL6.0
Comment 1 Zbysek MRAZ 2011-04-18 08:16:29 EDT

*** This bug has been marked as a duplicate of bug 697470 ***

Note You need to log in before you can comment on or make changes to this bug.