Bug 697510 - Gnome Shell Network Proxy not working.
Gnome Shell Network Proxy not working.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-18 09:38 EDT by rh
Modified: 2011-04-21 10:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-19 13:13:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 647077 None None None Never

  None (edit)
Description rh 2011-04-18 09:38:45 EDT
Description of problem:


Version-Release number of selected component (if applicable):

2.6.38.2-9.fc15.x86_64
gnome-shell-3.0.0.2-2.fc15.x86_64

How reproducible:

Steps to Reproduce:
1. Install Fedora 15 beta default Desktop installation.
2. Try set network proxy via "Network Settings (top panel/bar) - Network proxy". 
3. Test network to see if the proxy works.
  
Actual results:

The proxy settings does not have any effects - not work.

Expected results:

Should be work if defined.

Additional info:

In fedora 14 (and previous versions) the Gnome network proxy worked fine.
Comment 1 Reinout van Schouwen 2011-04-19 04:52:59 EDT
I was about to file the same bug. Running Privoxy locally, it is simply ignored by both Firefox and Epiphany. (Checked by loading http://config.privoxy.org/ which should be intercepted if the proxy is working.)
Comment 2 Reinout van Schouwen 2011-04-19 04:54:52 EDT
Probably related to bug 691627.
Comment 3 rh 2011-04-19 06:39:20 EDT
That bug is for XULRunner, but this was raised because the proxy does not work in Desktop environment (including terminal) in general.
Comment 4 Dan Winship 2011-04-19 10:42:53 EDT
What specific programs are you using that are not respecting the proxy settings? The control panel is setting the proxy settings correctly, but some programs may still be looking for them in the old (GNOME 2.x) location.
Comment 5 rh 2011-04-19 12:47:18 EDT
For example software updates does not work or if you try yum update/installs in the terminal. In Fedora 14 'env' command in terminal shows that http_proxy/https_proxy is set. In fedora 15, it does not set these variables.
Comment 6 Dan Winship 2011-04-19 13:13:06 EDT
Ah, gnome-terminal is still looking in GConf for the proxy settings. There's a patch upstream. We should be able to get this into GNOME 3.0.1 and into F15 from there.
Comment 7 Reinout van Schouwen 2011-04-21 05:44:15 EDT
(In reply to comment #6)
> Ah, gnome-terminal is still looking in GConf for the proxy settings. There's a
> patch upstream. We should be able to get this into GNOME 3.0.1 and into F15
> from there.

Like I said in comment #1, the problem also affects browsers such as Epiphany and Firefox as well as Chromium.
Comment 8 Dan Winship 2011-04-21 10:20:08 EDT
Epiphany should not be affected if you have libsoup >= 2.33.92 and glib-networking >= 2.28.4. If it is, that's a separate bug. Firefox is 691627. Chromium would be yet another bug. (The bug being "it's still looking in gconf rather than having been updated to look in gsettings".)

Note You need to log in before you can comment on or make changes to this bug.