Bug 697520 - The old SysV initscript should be packaged into subpackage when replaced with systemd one
Summary: The old SysV initscript should be packaged into subpackage when replaced with...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cronie
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-18 14:05 UTC by Jóhann B. Guðmundsson
Modified: 2011-05-09 04:05 UTC (History)
3 users (show)

Fixed In Version: cronie-1.4.7-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-09 04:05:01 UTC


Attachments (Terms of Use)

Description Jóhann B. Guðmundsson 2011-04-18 14:05:32 UTC
Description of problem:

The old SysV initscript should be package into seperate subpackage when replaced with a native systemd one to avoid confusion amongs end users since systemd will use the native systemd service file when it exist by default thus rendering the old sysv obsolete and keeping it around will only confuse users that for one reason or another are editing the sysv init script.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Marcela Mašláňová 2011-04-26 11:45:06 UTC
Could you point me to the valid guide line? I'd like to have this change correct. Also I believe this change should be done in rawhide, not F-15.

Comment 2 Fedora Update System 2011-05-06 07:02:24 UTC
cronie-1.4.7-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/cronie-1.4.7-2.fc15

Comment 3 Fedora Update System 2011-05-07 15:05:51 UTC
Package cronie-1.4.7-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cronie-1.4.7-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/cronie-1.4.7-2.fc15
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-05-09 04:04:51 UTC
cronie-1.4.7-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.