This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 697532 - The old SysV initscript should be packaged into subpackage when replaced with systemd one
The old SysV initscript should be packaged into subpackage when replaced with...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iputils (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
: 714715 (view as bug list)
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-04-18 10:29 EDT by Jóhann B. Guðmundsson
Modified: 2014-11-09 17:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 09:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Spec file which drops SysV support for rdisc.service (17.76 KB, text/plain)
2011-06-24 12:37 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-18 10:29:19 EDT
Description of problem:

The old SysV initscript should be package into seperate subpackage when replaced with a native systemd one to avoid confusion amongs end users since systemd will use the native systemd service file when it exist by default thus rendering the old sysv obsolete and keeping it around will only confuse users that for one reason or another are editing the sysv init script.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jiri Skala 2011-06-20 11:04:20 EDT
*** Bug 714715 has been marked as a duplicate of this bug. ***
Comment 2 Jóhann B. Guðmundsson 2011-06-24 12:37:46 EDT
Created attachment 509808 [details]
Spec file which drops SysV support for rdisc.service

This spec file drops legacy sysv support if you have any intention of continuing supporting the legacy sysv init script please follow the official packaging guideline for systemd and package it in a seperate subpackage.

Thank you.

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
Comment 3 Jiri Skala 2011-06-27 09:15:22 EDT
SysV initscript has been moved into separate subpackage.
Comment 4 Jiri Skala 2011-06-27 09:30:10 EDT
*** Bug 716923 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.