Bug 697533 - The old SysV initscript should be packaged into subpackage when replaced with systemd one
The old SysV initscript should be packaged into subpackage when replaced with...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Heinrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-04-18 10:31 EDT by Jóhann B. Guðmundsson
Modified: 2011-09-08 15:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-08 15:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-18 10:31:05 EDT
Description of problem:

The old SysV initscript should be package into seperate subpackage when replaced with a native systemd one to avoid confusion amongs end users since systemd will use the native systemd service file when it exist by default thus rendering the old sysv obsolete and keeping it around will only confuse users that for one reason or another are editing the sysv init script.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-06-24 13:40:07 EDT
Please follow the packaging guidelines and remove the old legacy sysv init script or package it in a seperate subpackage. 

Thank you.

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
Comment 2 Jóhann B. Guðmundsson 2011-07-15 10:49:04 EDT
What's the current status of this you are then only one that is not package
native systemd unit in the Core group correctly?

If you dont have the time to fix this should I try to find a proven packager to do this for you? 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 3 Tom "spot" Callaway 2011-09-08 15:05:19 EDT
This is fixed in rsyslog-5.8.5-1.fc16, currently in updates-testing. Closing.

Note You need to log in before you can comment on or make changes to this bug.