This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 697544 - Hibernate does not work on a Toshiba NB555D
Hibernate does not work on a Toshiba NB555D
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2011-04-18 10:48 EDT by Peter H. Jones
Modified: 2012-07-11 13:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 13:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of dmesg command (63.04 KB, application/octet-stream)
2011-04-18 10:48 EDT, Peter H. Jones
no flags Details
dmesg of Linux version 2.6.38.8-32..fc15.x86_64.debug (59.40 KB, text/plain)
2011-07-11 11:23 EDT, Peter H. Jones
no flags Details
dmesg of Linux version 2.6.38.8-35..fc15.x86_64 (58.74 KB, text/plain)
2011-07-11 12:06 EDT, Peter H. Jones
no flags Details
dmesg output (66.59 KB, text/plain)
2012-03-28 17:07 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2011-04-18 10:48:59 EDT
Created attachment 492909 [details]
output of dmesg command

Description of problem:
Hibernate function is not available in Fedora. It is in the Microsoft
Windows 7 that came with the machine. It uses file HIBERFIL.SYS in
the Windows partition.

Version-Release number of selected component (if applicable):


Additional info:

dmesg output (attached) contains:
" PM: Hibernation image not present or could not be loaded."

The machine is sold with 4 primary partitions in use. To install Fedora, I backed up partition 2, containing Windows, with tar. Then I deleted Partition 2 and created a secondary partition, and divided that into logical partitions. Then I restored the backed-up Windows files into a logical partition. When I rebooted, Windows did an automatic self-repair, and found the restored partition.

I then installed Fedora into other logical partitions. I had to edit the grub.conf to boot from partition sda1 (numbered 0 in grub), for otherwise anaconda finds the restored Windows partition, and booting from that starts the restore disk dialogue, which would result in erasing all the previous work.
Comment 1 Peter H. Jones 2011-07-10 22:41:50 EDT
Tried with kernel-3.0-0.rc6.git0.1.fc16.x86_64 . Hibernate seems to power
off, but when I power up again, the system appears to restart and the screen
contents reappear. However, the clock does not advance, and the screen
blinks off and reappears every few seconds. Furthermore, there is no
apparent response to the keyboard, mouse pad or even a quick jab to the
power key. Hence, I cannot use CTRL-ALT-Fx to login and get a root shell.
I have to power down and restart. I'd like to know how to save and post further debugging information to help solve this bug.

I am running the development kernel in an otherwise F15 system.
Comment 2 Peter H. Jones 2011-07-11 11:20:17 EDT
Tried today with 2.6.38.8-32.fc15.x86_64.debug, the regular kernel. I observed the following:
1) Saving appeared normal.
2) After restore power-on, the grub menu appeared, instead of flashing by
briefly, as it did with kernel-3.0-0.rc6.git0.1.fc16.x86_64, so kernel-3 is an improvement. I made sure I selected the same kernel and parameters for the restore.
3) Screen reappeared as before hibernate. Clock did not advance. Cursor also appeared, but had a strange shape: it looked like a postage-stamp-sized triple of some text pixels on the screen. There was no apparent response to the mouse buttons (I tried lassoing, and bottom corners of the screen.).
4) Display would blank and reappear every few seconds. Once, it went to a colourless screen, like deep-fringe reception on analog TV. Then the cursor arrow appeared as normal, but still no response to the mouse buttons.
5) I was able to CTRL-ALT-F2 and get a login prompt. While trying to log in, a trace message with something like "Xorg" and "tainted'. If I knew if these traces are saved somewhere, I'd be happy to post them.
6) Despite the traces messages, I was able to login and shutdown -h now.
Comment 3 Peter H. Jones 2011-07-11 11:23:48 EDT
Created attachment 512242 [details]
dmesg of Linux version 2.6.38.8-32..fc15.x86_64.debug
Comment 4 Peter H. Jones 2011-07-11 12:06:38 EDT
Created attachment 512255 [details]
dmesg of Linux version 2.6.38.8-35..fc15.x86_64

Tried Hibernate with kernel-2.6.38.8-35.fc15.x86_64 . Saving worked. After power-on to resume, grub menu flashed briefly, as expected. Screen display reappeared, clock did not advance. Screen blanked out and reappeared every few seconds. No apparent response to keys or mouse.
Comment 5 Peter H. Jones 2011-07-12 14:55:52 EDT
Works with kernel 2.6.38.8-35.fc15.x86_64 with nomodeset kernel parameter added.
Comment 6 Peter H. Jones 2011-08-22 17:51:47 EDT
Still need nomodeset with kernel 2.6.40.3-0.fc15.x86_64 .
Comment 7 Josh Boyer 2012-03-28 14:02:27 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.
Comment 8 Peter H. Jones 2012-03-28 16:56:04 EDT
This version boots, but I don't see a Hibernate option in the logout menu.
Comment 9 Peter H. Jones 2012-03-28 17:07:29 EDT
Created attachment 573460 [details]
dmesg output

Attaching dmesg output. Note that I'm currently running a FC15 system.
Comment 10 Josh Boyer 2012-06-04 14:29:31 EDT
(In reply to comment #8)
> This version boots, but I don't see a Hibernate option in the logout menu.

What do /sys/power/state and /sys/power/disk have for values?
Comment 11 Josh Boyer 2012-07-11 13:53:08 EDT
Fedora 15 has reached it's end of life as of June 26, 2012.  As a result, we will not be fixing any remaining bugs found in Fedora 15.

In the event that you have upgraded to a newer release and the bug you reported is still present, please reopen the bug and set the version field to the newest release you have encountered the issue with.  Before doing so, please ensure you are testing the latest kernel update in that release and attach any new and relevant information you may have gathered.

Thank you for taking the time to file a report.  We hope newer versions of Fedora suit your needs.

Note You need to log in before you can comment on or make changes to this bug.