This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 697612 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-04-18 14:25 EDT by Jóhann B. Guðmundsson
Modified: 2011-09-08 15:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-08 15:10:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file for smolt (266 bytes, text/plain)
2011-04-18 14:25 EDT, Jóhann B. Guðmundsson
no flags Details
New and improved version of smolt systemd service file.. (405 bytes, text/plain)
2011-04-19 20:22 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-18 14:25:25 EDT
Created attachment 492978 [details]
Native systemd service file for smolt

Description of problem:

I'm unsure if this is supposed to be a service file et all since it does not seem to be used by anything anyway...

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Will Woods 2011-04-19 19:10:20 EDT
The only thing the init script is supposed to do (as far as I can tell) is to create /etc/smolt/hw-uuid if it doesn't exist. The lockfile is useless. 

All it really needs to do is:

if [ ! -f /etc/smolt/hw-uuid ]; then
    cat /proc/sys/kernel/random/uuid > /etc/smolt/hw-uuid
    chmod 0644 /etc/smolt/hw-uuid
    chown root.root /etc/smolt/hw-uuid
fi

But I'm not really sure how to make a systemd unit that does that. 

The monthly checkin itself is triggered by a cron job.
Comment 2 Jóhann B. Guðmundsson 2011-04-19 20:22:58 EDT
Created attachment 493326 [details]
New and improved version of smolt systemd service file..

Well technically since this is not an service daemon something else should create this like the application that offers the end user to enable monthly smolt updates but since systemd is so awesome and beefy let's do it.

The service vill refuse to run if /etc/smolt/hw-uuid does exit and once it has run it will disable itself encase something enabled it as a good run once service should do..
Comment 3 Lennart Poettering 2011-04-26 09:22:36 EDT
I think a nice solution would be to use /etc/machine-id instead of a uuid of its own for identifying the machine. For more details see http://0pointer.de/blog/projects/the-new-configuration-files.html
Comment 4 Jóhann B. Guðmundsson 2011-04-26 11:42:46 EDT
The cron job is triggered by the existence of the /etc/smolt/hw-uuid and the only thing that this so called service does is to create that file. 

Why this is an sysv init script beats the hell out of me ( as opposed to be something like smolt --enable-monthly cmd that either get run by user of by something else like firstboot )
Comment 5 Bill Nottingham 2011-04-26 13:35:23 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 6 Jóhann B. Guðmundsson 2011-06-27 18:04:43 EDT
What's the current status on this? 

Please follow the following guidelines to package the service correctly.

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
http://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 7 Jóhann B. Guðmundsson 2011-07-18 05:57:06 EDT
Will what's the hold up ?
Comment 8 Tom "spot" Callaway 2011-09-08 15:10:15 EDT
1.4.3-4 removed the pointless initscript and 1.4.3-5.fc16 is stable now.

Note You need to log in before you can comment on or make changes to this bug.