Bug 697695 - Account policy plug-in affects the password policy attributes.
Account policy plug-in affects the password policy attributes.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.1
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
: screened
Depends On: 691446
Blocks: 434915 639035
  Show dependency treegraph
 
Reported: 2011-04-18 18:32 EDT by Rich Megginson
Modified: 2015-01-04 18:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 691446
Environment:
Last Closed: 2011-04-21 14:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 RHEL Product and Program Management 2011-04-19 02:00:44 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Nathan Kinder 2011-04-21 14:45:33 EDT
I tried to reproduce this issue, and everything is working as designed.

I believe I know why it looked like it was not behaving correctly.  When using password expiration, the expiration time is reset first time a user does a bind after a password change.  The expiration time is updated by adding the passwordWarning period to the existing expiration time.  By default, this is 1 day.  This means that a password will not expire for 1 day and 30 seconds if you set a 30 second expiration period and you bind within 30 seconds of changing the password (unless you change the passwordWarning value).  I believe that this was happening, which made it look like the Account Policy plug-in was overriding the password policy.  The best way to do this test is to set passwordWarning to 0 in the password policy.  This will ensure that the password expires after 30 seconds as expected.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.