Bug 69776 - kickstart with bootnet.img does not find SCSI disks
kickstart with bootnet.img does not find SCSI disks
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-25 05:38 EDT by Georg Baumann
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 14:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the kickstart file I used (1.76 KB, text/plain)
2002-07-25 05:42 EDT, Georg Baumann
no flags Details

  None (edit)
Description Georg Baumann 2002-07-25 05:38:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
when using bootnet.img to do a kickstart installation, then the installer will not load the aic7xxx module; when doing a graphical install with the same diskette, then aic7xxx is loaded automatically

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create boot disk from bootnet.img
2. boot SCSI system with this disk
3. start with "linux ks" (or with "linux ks=floppy" if a ks.cfg
   has been copied to it)
 

Actual Results:  ERROR: no valid devices were found on which to create new filesystems

Expected Results:  successfull installation; with RH 7.2 this did work without any problems

Additional info:

when doing a standard installation instead of "kickstart", then everything works fine (with the same boot floppy)
Comment 1 Georg Baumann 2002-07-25 05:42:29 EDT
Created attachment 67004 [details]
the kickstart file I used
Comment 2 Georg Baumann 2002-07-29 10:39:20 EDT
 Found the problem: this was not a bug in loading the SCSI driver, but I 
forgot to update my kickstart file. It still did point to an image of RedHat 
7.2 instead of 7.3. But the error message "no valid devices were found on 
which to create new filesystems" was very confusing! Now I corrected the 
pointer and everything works fine. 
 
I.e. the only bug is showing a misleading error message. 
Comment 3 Jeremy Katz 2002-08-02 16:30:31 EDT
This is why current releases now double-check a timestamp file and verify that
they match if it exists on both images.  Unfortunately, we can't change legacy
behavior of the boot disks.  And the message is completely valid that we don't
have any block devices to install to.

Note You need to log in before you can comment on or make changes to this bug.