Bug 697774 - NetworkManager crashes when connecting to VPN (REGRESSION)
Summary: NetworkManager crashes when connecting to VPN (REGRESSION)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 14
Hardware: x86_64
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 698669 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-19 08:38 UTC by Matthew Booth
Modified: 2011-05-26 21:52 UTC (History)
4 users (show)

Fixed In Version: NetworkManager-0.8.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-28 02:03:56 UTC


Attachments (Terms of Use)
NetworkManager crash output (10.87 KB, text/plain)
2011-04-19 08:38 UTC, Matthew Booth
no flags Details

Description Matthew Booth 2011-04-19 08:38:01 UTC
Created attachment 493125 [details]
NetworkManager crash output

Description of problem:
When connecting to my corporate VPN, NetworkManager crashes every time. I've attached what appears to be gdb output which it spits out to syslog.

This is a regression introduced in a recent update to updates-testing. After downgrading NetworkManager and NetworkManager-gnome, VPN connections are working again.

Version-Release number of selected component (if applicable):
NetworkManager.x86_64 1:0.8.3.999-2.git20110414.fc14

How reproducible:
100%

Steps to Reproduce:
1. Click NetworkManager in systray, VPN Connections->Corp VPN
2. Enter password
3. Wait a couple of seconds

Comment 1 Jirka Klimes 2011-04-19 14:17:05 UTC
Already fixed upstream:
ec21111aa7c02080028b600787effb888e779c8e

Please use stable version in the meantime.

Comment 2 Fedora Update System 2011-04-20 22:42:46 UTC
NetworkManager-0.8.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.4-1.fc14

Comment 3 Fedora Update System 2011-04-20 22:44:15 UTC
NetworkManager-0.8.4-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.4-1.fc13

Comment 4 Fedora Update System 2011-04-21 22:27:45 UTC
Package NetworkManager-0.8.4-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.4-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.4-1.fc14
then log in and leave karma (feedback).

Comment 5 David Kovalsky 2011-04-22 12:05:45 UTC
*** Bug 698669 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2011-04-28 02:03:06 UTC
NetworkManager-0.8.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-05-26 21:52:19 UTC
NetworkManager-0.8.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.