Bug 69780 - /usr/include/linux/autoconf.h contains #error Invalid kernel header included in userspace
Summary: /usr/include/linux/autoconf.h contains #error Invalid kernel header included ...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc-kernheaders   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-25 10:37 UTC by Need Real Name
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-25 10:37:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-07-25 10:37:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
autoconf.h in glibc-kernheaders-2.4-7.14 and glibc-kernheaders-2.4-7.16 
contains 
#error Invalid kernel header included in userspace.
Is it normal ???

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.download lvm, lm_sensors, ...
2.compiling doesn't work because autoconf.h is bad
3.
	

Additional info:

Comment 1 Arjan van de Ven 2002-07-25 10:40:55 UTC
ANYTHING that includes that header is VERY VERY broken. There is nothing we can
put in that header that makes sense it's a private, kernel internal header.

btw be careful with upgrading lvm userspace to a "newer" version; we fixed
several datacorruption bugs in the lvm package we ship (and sent them to sistina
but got no response)



Note You need to log in before you can comment on or make changes to this bug.