Bug 69782 - gftp problems with lang and fonts
gftp problems with lang and fonts
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gftp (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-25 07:42 EDT by Mattias Dahlberg
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 17:28:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Dahlberg 2002-07-25 07:42:22 EDT
Description of problem:

Two screenshots to illustrate the problem:

http://users.du.se/~mda/gftp1.png
http://users.du.se/~mda/gftp2.png

The LANG is "sv_SE.UTF-8" as configured by Anaconda for Swedish. Somehow the 
translated menus get mixed up with the English menus, resulting in some menu 
lables showing up twice (translated and untranslated) and some menu lables not 
showing up at all. This also leads to buggy menu entries, as seen in the 
screenshots.

I _have_ installed XFree86-75dpi-fonts-4.2.0-52.i386.rpm and XFree86-100dpi-
fonts-4.2.0-52.i386.rpm, which weren't installed by default in Limbo.

I tried with gftp-2.0.13-1.i386.rpm from Rawhide as well; no difference.


How reproducible:
Always

Steps to Reproduce:
1. Install Limbo (and X fonts)
2. Use Swedish LANG
3. Run gftp
Comment 1 Havoc Pennington 2002-07-25 15:00:04 EDT
It would probably be helpful to try the next beta that comes out. Or Owen may
know specific packages you could try upgrading.
Comment 2 Owen Taylor 2002-07-25 15:30:30 EDT
"I tried with gftp-2.0.13-1.i386.rpm from Rawhide as well" - as well
as what? gftp .po files were broken for Swedish (and various other
locales) before 2.0.12-1; I put in some fixes in 2.0.12-1
(I didn't actually test the Swedish fix, but it should have been
simple.)

I'd like to know whether this is a regression in 2.0.13-1, or
a continuing bug.
Comment 3 Owen Taylor 2002-07-25 15:41:06 EDT
In some checking, it's a 2.0.13-1 specific screwage. LOoks like
somehow the author managed to merge my fixes from 2.0.12-1 but
not regenerate the .gmo files. I think adding a rm po/*.gmo to
the spec file should fix.
Comment 4 Owen Taylor 2002-07-25 15:53:45 EDT
OK, fixed in 2.0.13-2, suggestion sent to the gftp author that
he upgrade his gettext.
Comment 5 Mattias Dahlberg 2002-07-26 03:05:37 EDT
otaylor@redhat.com wrote:

> "I tried with gftp-2.0.13-1.i386.rpm from Rawhide as well" - as well
> as what?

As well as the version included with Limbo.

> OK, fixed in 2.0.13-2, suggestion sent to the gftp author that
> he upgrade his gettext.

Ok, I'll try 2.0.13-2 when it hits rawhide.


Comment 6 Mattias Dahlberg 2002-07-30 06:02:47 EDT
Not entirely fixed I'm afraid. Now the "empty menus" are gone, but I still get 
every menu twice, once in English and once in Swedish. Some options are 
available in both menus, but some options appear only in one of them.

This is with gftp-2.0.13-2, running in Limbo 2.
Comment 7 Havoc Pennington 2002-07-30 09:48:21 EDT
I don't even begin to understand how the menus could get duplicated... 
Comment 8 Havoc Pennington 2002-08-14 17:21:08 EDT
So it gets weirder - only Swedish is broken. German, French, Spanish are all fine.
Comment 9 Havoc Pennington 2002-08-14 17:28:49 EDT
Japanese also broken.
Comment 10 Owen Taylor 2002-08-21 22:20:25 EDT
Turned out that the way gftp did translations, things broke really
badly if you had a partial translation (as for Swedish). I've
put a patch into 2.1.13-5 that reworks the menu handling a bit
and sent it to the gftp author... it seems to make the 
Swedish menus show up properly. (They aren't fully translated,
but that's just a deficiency of the translation.)
Comment 11 Mattias Dahlberg 2002-08-22 02:45:59 EDT
Thank you very much, Owen.

Note You need to log in before you can comment on or make changes to this bug.