Bug 697855 - Reports->Configuration History: User without configure read permissions can view a config history of a resource in reports
Reports->Configuration History: User without configure read permissions can v...
Status: CLOSED DUPLICATE of bug 696648
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-19 09:07 EDT by Sunil Kondkar
Modified: 2011-10-04 15:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-19 15:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sunil Kondkar 2011-04-19 09:07:10 EDT
Description of problem:
User without configure read permissions can view a config history of a resource in Reports->Configuration History page.

Version-Release number of selected component (if applicable):

build#1144 (Version: 4.0.0-SNAPSHOT Build Number: 50f58a4)


How reproducible:

Always

Steps to Reproduce:

1. Login to RHQ as rhqadmin.
2. Create a user and a compatible group of resorces (Ex: RHQ Agent).
3. Create a role with no permissions.
4. Assign the resource group and the user created to the role.
5. Logout and login as the user created above( with no permissions)
6. Navigate to Reports->Configuration History.

  
Actual results:
The Reports->Configuration History displays the config history rows for the resource(RHQ Agent)


Expected results:
User without configure read permissions should not be able to view config history of a resource.

Additional info:
When the same user (without configure read permissions) navigates to the individual resource, the 'Configuration' tab is disabled as expected.
Comment 1 Jay Shaughnessy 2011-04-19 15:48:11 EDT
This issue was already solved. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 696648 ***

Note You need to log in before you can comment on or make changes to this bug.