Bug 697870 - portlet config buttons throw globally uncaught exception
portlet config buttons throw globally uncaught exception
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta1
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-19 09:59 EDT by John Mazzitelli
Modified: 2011-05-23 21:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-04-19 09:59:10 EDT
we need to go through all portlets and make sure the config buttons don't throw exceptions. I found two that do:

Resource : Operations
Resource : Alerts
Comment 1 Jay Shaughnessy 2011-04-19 10:22:20 EDT
I couldn't reproduce. Was this just clicking the config icon?  I tried several resource and group portlets. They all worked for me.

Maybe an older build, or a specific platform/browser?
Comment 2 John Mazzitelli 2011-04-19 11:42:17 EDT
looks like this has already been fixed, I was testing on an older version.

To test, go to all portlets in global dashboard, resource dashboard (Summary>activity) and group dashboard (Summary>activity) and make sure you can click on all config icons and not get ugly red errors.
Comment 3 Sunil Kondkar 2011-05-12 08:03:25 EDT
Verified on rhq4 release build (Version: 4.0.0 Build Number: db0c817)

Navigated to portlets in global dashboard, resource dashboard
(Summary>activity) and group dashboard (Summary>activity) and clicked on configuration icon. No Exception is observed. 

Marking as verified.
Comment 4 Corey Welton 2011-05-23 21:12:06 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:12:06 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.