Bug 6979 - LILO config doesn't offer /boot partition
LILO config doesn't offer /boot partition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-12 22:34 EST by Joe Harrington
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 19:19:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 1999-11-12 22:34:48 EST
I made four partitions: /, /boot, /home, and swap.  The Lilo configuration
in the GUI install offered / and /home as bootable partitions.  The boot
flag in the partition table was only set on /boot.  The kernels ended up in
/boot because it was mounted.  LILO went to the MBR.  Perhaps I'm not
understanding the question, in which case the screens and the install guide
need to be made much clearer.  It is not clear from the manual or from the
screen help whether the "Partition:" section of the LILO Configuration
Screen is looking for the root of the filesystem to boot (regardless of the
fact that the kernels won't be mounted at boot time) or the location of the
kernels.  Things are working, so this is probably a documentation problem.

--jh--
Comment 1 Jay Turner 1999-11-29 15:04:59 EST
The GUI installer should be offering to install lilo in one of two places for
your system, either the MBR of the drive or the first sector of the boot
partition.  In the case where there is not a separate /boot partition, then this
second option becomes installing to the first sector of the root partition (as
/boot would actually reside on the / partition in this case!)

Anyway, there should not have been an option to install lilo to the /home
partition, and if there really was, then I would definitely say we have a
problem.

If there is no other operating system on your machine, then you will want to
install lilo to the mbr of the drive, as there is no reason not to do that.  The
only time that you will need to worry about installing lilo to the first sector
of the boot partition is when there are other operating systems on the machine
and thus already another boot loader written to the MBR of the drive.

The kernels should end up in /boot, as that is the place for all kernels on your
system, so the installer was acting correctly in doing that.

Please reopen this bug if you are have problems with the lilo installation or if
you have further questions about lilo and its placement.
Comment 2 Joe Harrington 1999-12-21 17:03:59 EST
I think maybe I wasn't clear.  Look at the picture in
file:/usr/doc/rhl-ig-6.1en/s1-cd-rom-gui-lilo-conf.html
The "Install LILO boot record on" section was as shown.  The "Partition" section
also looked roughly as shown.  After going through the effort of making a boot
partition, I was looking for a place to tell the installer that's where I want
my kernels.  So, I'm surprised not to see it in the "partition" section.
Looking much closer at the accompanying docs, I now understand that it wants the
partition on which to put the root of the Linux filesystem, and that /boot gets
the kernels just by virtue of being mounted with that name when the OS
installs.  I don't understand why /home was offered, as it had no bootable flag
in the partition table.  I had not yet named it /home (I use -m0 in mkfs and do
it myself), so maybe that's why.  Anyway, the screen talks about "boot image"s,
not OS roots, and boot images are in /boot.  The words in this part of the
screen should be more clear since there is more than one "partition"-related
thing going on, and the one involving "boot image"s isn't the one being talked
about.  Maybe "OS Root Partition" and "boot by default" would be better. Just my
$0.02.

--jh--
Comment 3 Jay Turner 2000-02-08 19:18:59 EST
The reason that your /home partition (which you had not labelled as /home yet)
appeared in the "Partitions" section is because the installer does not know
whether this is another linux installation that you would like to boot or what.
All the installer sees is an ext2 filesystem and it therefore lists it as a
possibility for booting from lilo.
You are correct that the middle portion of the screen is asking where you would
like to install lilo.  If there are no other operating systems on the system,
then there is no reason to not install to the MBR of the drive, but some people
have things like System Commander or NT, which require that the MBR be devoted
to those, therefore lilo must me installed to the first sector of the boot
partition.
In the bottom portion of the screen, the installer makes reference to "boot
images."  This is the correct terms, as lilo's function is to redirect the BIOS
of the machine to the appropriate boot image to boot an operating system.
People frequently set up entries to get into System Utilities partitions as well
as other operating systems.
If you would like to make comments about the installation guide, feel free to
send comments to docs@redhat.com.

Note You need to log in before you can comment on or make changes to this bug.