Bug 69791 - up2date -l exits with errors
up2date -l exits with errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-25 10:32 EDT by Michael Young
Modified: 2015-01-07 18:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 05:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2002-07-25 10:32:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; SunOS 5.9 sun4u)

Description of problem:
I can update named packages from the command line using up2date, but if I try to
list the packages that still need to be upgraded, I get the error "Not Found",
after fetching the Obseletes list looks to have finished. My guess if that there
is a file missing on the server (maybe associated to the nmap package, but that
is a guess at the moment), though a more helpful error message would have been
nice.
This is with up2date*-2.9.27-7.x.9 and rhnlib-0.8-11.

How reproducible:
Always

Steps to Reproduce:
1. up2date -l
Comment 1 Michael Young 2002-07-25 12:11:37 EDT
I have now upgraded all packages marked as requiring update on the rhn site, and
I still get the same error. (so my guess about nmap was wrong).
Comment 2 Michael Young 2002-07-29 04:23:23 EDT
The Not Found problem has gone away (presumably a server change), I am now
getting the following output
...
Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
file /usr/bin/magicfilter-t from install of printconf-0.4.5-1 conflicts with
file from package redhat-config-printer-0.4.14-1
 Clearly this is because redhat-config-printer replaces printconf, but I don't
have printconf installed, so I don't understand why up2date -l is checking this
in the first place.
Comment 3 Michael Young 2002-07-29 05:16:12 EDT
Actually, I do understand it. I had rhs-printfilters installed, (because HP web
jetadmin reinstalled it), which is obsoleted by printconf according to
redhat-beta-limbo-i386-obsoletes.20020718002946
Of course it should now be obsoleted by redhat-config-printer, so your obsoletes
list needs updating.
Comment 4 Michael Young 2002-07-30 04:43:11 EDT
The obsoletes file has been corrected, so I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.