Bug 697937 - alert definition view shows invalid alert defs
alert definition view shows invalid alert defs
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-19 13:30 EDT by John Mazzitelli
Modified: 2011-05-23 21:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-04-19 13:30:37 EDT
create some alert defs - resource, group, template.

Go to any resource's Alert definition subtab - doesn't even have to be a resource that has an alert defined for it.

Click the table refresh button.

notice you get an odd list of alert defs that aren't related to the resource.

org.rhq.enterprise.gui.coregui.client.alert.definitions.ResourceAlertDefinitionsDataSource.getFetchCriteria(DSRequest)

line 132:             Map values = requestCriteria.getValues();

that should be returning a map that contains the resource ID, but it is empty
hence why the criteria doesn't filter on ID and we get everything

the first time through, that map DOES contain the resource ID, so it works
pressing "refresh", and that map is empty. the criteria is screwed upon refresh

I predict the problem is occuring somewhere in or around org.rhq.enterprise.gui.coregui.client.components.table.Table.refresh()
Comment 1 Jay Shaughnessy 2011-04-19 14:57:09 EDT
commit 9f4c5ba9c65c708a90b6c40916949c91c3262e40
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Tue Apr 19 14:55:10 2011 -0400

    [BZ 697937 - alert definition view shows invalid alert defs]
    The way the alert def list views were implemented no longer played well
    with the Table mechanism with respect to refresh. The resource/group/type id
    criteria was lost after the initial fetch.

    Changed the impl to use fixed InitialCriteria.
Comment 2 Sunil Kondkar 2011-05-06 03:31:43 EDT
Verified on rhq4 release build (Version: 4.0.0 Build Number: db0c817)

created alert definitions on a resource, group and template.

Navigated to other resource's Alert definition sub tab and clicked the table refresh button. Also verified this on the resource, group and template alert definition tab (where alert definitions are created). Clicking Refresh button does not display any other alert definitions that aren't related to the resource.

Marking as verified.
Comment 3 Corey Welton 2011-05-23 21:15:36 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:15:37 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:15:38 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:15:43 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.