Bug 697946 - Wireless does not work on F15 beta
Wireless does not work on F15 beta
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:ed77582d868ad15281e9ec24451...
: Regression
: 714415 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-19 14:20 EDT by Alex Williamson
Modified: 2012-08-07 11:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 11:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: event_log (20.98 KB, text/plain)
2011-04-19 14:20 EDT, Alex Williamson
no flags Details
File: smaps (36.57 KB, text/plain)
2011-04-19 14:20 EDT, Alex Williamson
no flags Details
File: dsos (5.08 KB, text/plain)
2011-04-19 14:20 EDT, Alex Williamson
no flags Details
File: maps (7.42 KB, text/plain)
2011-04-19 14:20 EDT, Alex Williamson
no flags Details
File: backtrace (17.35 KB, text/plain)
2011-04-19 14:20 EDT, Alex Williamson
no flags Details
Danny backtrace (6.75 KB, text/plain)
2011-04-21 10:41 EDT, Danny George
no flags Details

  None (edit)
Description Alex Williamson 2011-04-19 14:20:09 EDT
abrt version: 2.0.0
executable: /usr/sbin/wpa_supplicant
cmdline: /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -B -u -f /var/log/wpa_supplicant.log -P /var/run/wpa_supplicant.pid
component: wpa_supplicant
architecture: x86_64
crash_function: _dbus_abort
kernel: 2.6.38.2-9.fc15.x86_64
uid: 0
reason: Process /usr/sbin/wpa_supplicant was killed by signal 6 (SIGABRT)
package: wpa_supplicant-0.7.3-4.fc15
username: root
rating: 4
os_release: Fedora release 15 (Lovelock)
time: 1303235875

Text file: event_log, 21482 bytes
Text file: smaps, 37451 bytes
Binary file: coredump, 1007616 bytes
Text file: dsos, 5207 bytes
Text file: maps, 7603 bytes
Text file: backtrace, 17762 bytes

build_ids
-----
9fd7f9c1f8b41211bd210e10f915ef69cea6a2ee
e5f626726497a81807681ed0088dbce6d6a1f17b
8f67031b50aa96f0a6ae7c89efed129297831c5d
9ef41f9ca0eabaf3a03dd77eb180e202ab4fe956
a16b0670d7225713927fe76b775bdc157c105b51
f952662bc1e468db5be0d68ccd8e107424d3d4f1
1ba57a696637c1e23edecbd851a292f85214b29c
1055ac8cb851ad0f25c1533682ed949a1d85c826
89017ab0b75e533e4294f74ee8f7db3daceea536
491c7ad109d751508a100e2f33fdacdebeceb8ad
d83f52ed9dfe5d1f2914404c798e6b2579b15c40
2f709c0d80b7741b678d35892b3ffacecc03d50c
29c7c0f8e5432e069ddc7312e4f1cde8659d0076
15e31091755a8e7a6ece970b556da47f930e0485
adc7519e0f91474d58bd87949e67e1d560d0e4c5
e56a1c53a3cc7096355bdae521a2bf98041de78d
5cc111ce758441128d08b5bc105a37addbc28a93
13110e8b350c1a3bd2097f130b9d1cbbc50931a0
30ca51463a8366261b0d0f4174939ec6324c5452
d54647ce3fe0f70c8d886886d69b0fb5038371fa
f72110c13d608db42e73fcf708df9f1d0efe07f5

comment
-----
Wireless doesn't work.  This is a standard iwlagn device:

10:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

The Network Settings dialog just cycles between "Unavailable" and "Disconnected".  F14 worked fine with the wireless on this laptop.
Comment 1 Alex Williamson 2011-04-19 14:20:11 EDT
Created attachment 493241 [details]
File: event_log
Comment 2 Alex Williamson 2011-04-19 14:20:13 EDT
Created attachment 493242 [details]
File: smaps
Comment 3 Alex Williamson 2011-04-19 14:20:15 EDT
Created attachment 493243 [details]
File: dsos
Comment 4 Alex Williamson 2011-04-19 14:20:17 EDT
Created attachment 493244 [details]
File: maps
Comment 5 Alex Williamson 2011-04-19 14:20:18 EDT
Created attachment 493245 [details]
File: backtrace
Comment 6 Alex Williamson 2011-04-19 14:26:52 EDT
I also see this same error on another laptop with an Intel Corporation Centrino Wireless-N 1000 device that also uses the iwlagn driver.  Wireless works fine on both of these laptops on F14.  Completely unavailable on F15.
Comment 7 Danny George 2011-04-21 10:31:51 EDT
Migrating my comments to this bug instead of https://bugzilla.redhat.com/show_bug.cgi?id=695959


> Same issue here with Dell M1330, Intel 4965 AG wireless card. F15 Live Beta
>
> 'nm-tool' shows nothing under Wireless Access Points
> 'iwlist wlan0 scanning' shows many networks detected
>
> Also, if I click on the NetworkManager icon and just leave it up, the Wireless
> section will intermittently switch between the On/Off slider and "unavailable".

wpa_supplicant version v0.7.3 (using LiveCD)

I was also asked to run abrt-gui to report the bug, but unless I'm missing something, no application crashes are being captured - even though I can still watch the wireless go back and forth between slider and unavailable.
Comment 8 Danny George 2011-04-21 10:41:36 EDT
Created attachment 493870 [details]
Danny backtrace
Comment 9 Colin Macdonald 2011-05-08 07:43:50 EDT
This might be bug #678625.
Comment 10 abrt-bot 2012-03-30 10:36:10 EDT
*** Bug 714415 has been marked as a duplicate of this bug. ***
Comment 11 Fedora End Of Life 2012-08-07 11:58:05 EDT
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.