Bug 698005 - eu-unstrip: do not seem to match
Summary: eu-unstrip: do not seem to match
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: binutils
Version: 6.1
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Andreas Schwab
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-19 21:38 UTC by Jan Kratochvil
Modified: 2011-12-06 17:00 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-12-06 17:00:18 UTC


Attachments (Terms of Use)
.tar.xz of ld and ld.debug (294.22 KB, application/octet-stream)
2011-04-19 21:38 UTC, Jan Kratochvil
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1523 normal SHIPPED_LIVE binutils bug fix and enhancement update 2011-12-06 00:50:07 UTC

Description Jan Kratochvil 2011-04-19 21:38:53 UTC
Created attachment 493297 [details]
.tar.xz of ld and ld.debug

Description of problem:
I wanted to merge binary and its .debug from Brew and I cannot.

Version-Release number of selected component (if applicable):
elfutils-0.152-1.el6.x86_64
binutils-2.20.51.0.2-5.17.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
eu-unstrip /tmp/ld /tmp/ld.debug 
  
Actual results:
eu-unstrip: '/tmp/ld' and '/tmp/ld.debug' do not seem to match

Expected results:
/tmp/ld containing both the code and the symbols.

Additional info:
http://download.devel.redhat.com/brewroot/packages/binutils/2.20.51.0.2/5.17.el6/x86_64/binutils-2.20.51.0.2-5.17.el6.x86_64.rpm
http://download.devel.redhat.com/brewroot/packages/binutils/2.20.51.0.2/5.17.el6/x86_64/binutils-debuginfo-2.20.51.0.2-5.17.el6.x86_64.rpm

Comment 1 Petr Machata 2011-04-20 17:20:31 UTC
EI_OSABI field of the debug file has value of 3 (Linux), in the stripped file it's 0 (UNIX - System V).  I think there was a fix recently regarding the ABI value in ELF file, so what happens might be that strip doesn't copy the header properly.

Comment 2 Petr Machata 2011-04-20 19:37:58 UTC
The problem is in binutils' strip, which is run as part of brp-strip-comment-note.  This zeroes the EI_OSABI value in ELF header.  Only non-debuginfo files are stripped this way, which explains why it can be here and not there.

# file ble
ble: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, not stripped

# strip -R .comment ble 

# file ble
ble: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped

Comment 3 Petr Machata 2011-04-20 19:39:42 UTC
# rpm -q binutils
binutils-2.20.51.0.2-5.19.el6.x86_64

Comment 11 errata-xmlrpc 2011-12-06 17:00:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1523.html


Note You need to log in before you can comment on or make changes to this bug.