Bug 698011 - [RS690] LiveCD doesn't boot into Gnome3. Only get background, no panel. Mouse clicks ignored.
Summary: [RS690] LiveCD doesn't boot into Gnome3. Only get background, no panel. Mouse...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 15
Hardware: i386
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-19 22:37 UTC by Phil Cole
Modified: 2018-04-11 12:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-09 12:54:22 UTC


Attachments (Terms of Use)
dmesg (67.44 KB, text/plain)
2011-04-19 22:37 UTC, Phil Cole
no flags Details
lspci -vv (20.53 KB, text/plain)
2011-04-19 22:38 UTC, Phil Cole
no flags Details
.xsession-errors (1.55 KB, text/plain)
2011-04-19 22:38 UTC, Phil Cole
no flags Details
Xorg.0.log (39.21 KB, text/plain)
2011-04-19 22:39 UTC, Phil Cole
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 37679 None None None Never
Launchpad 755791 None None None Never

Description Phil Cole 2011-04-19 22:37:39 UTC
Created attachment 493306 [details]
dmesg

Description of problem:
Gnome3 doesn't start properly from the Gnome3 live CD.

Version-Release number of selected component (if applicable):
Gnome3.

How reproducible:


Steps to Reproduce:
1. Get HP Compaq 6715b laptop.
2. Boot from F15 beta live CD
  
Actual results:
Cursor appears, gnome vertical striped blue background appears.  Mouse cursor moves.  Panel doesn't appear, just get blue background and nothing else. Mouse clicks are ignored.  Desktop completely unusable.

Expected results:
Panel should appear at top.  Mouse clicks should do something.

Additional info:
telinit 3, then startx *sometimes* gets the panel and activities panels to display, but then the desktop hangs with only the cursor being moveable.

Comment 1 Phil Cole 2011-04-19 22:38:23 UTC
Created attachment 493307 [details]
lspci -vv

Comment 2 Phil Cole 2011-04-19 22:38:49 UTC
Created attachment 493308 [details]
.xsession-errors

Comment 3 Phil Cole 2011-04-19 22:39:06 UTC
Created attachment 493309 [details]
Xorg.0.log

Comment 4 Phil Cole 2011-04-22 09:11:56 UTC
This may be a dupe of bug 683687.

Comment 5 Phil Cole 2011-05-19 00:29:39 UTC
Still get problem with latest nightly of Fedora 15, Fedora-15-Nightly-20110518.06-i686-Live-desktop.iso. Only way to get boot (from live CD and after installing to harddisk) is by adding "nomodeset" to the kernel paremeters on boot.

Comment 6 Matěj Cepl 2011-05-19 10:00:36 UTC
In my opinion, this is not an Xorg issue, but something about gdm or gnome-session. Reassigning.

Comment 7 Phil Cole 2011-05-28 07:18:03 UTC
I'm pretty sure this is an Xorg issue with the driver and this specific graphics chip.  Problem also reported here:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/755791

Comment 8 Phil Cole 2011-05-31 16:00:28 UTC
Upstream freedesktop.org bug: 
https://bugs.freedesktop.org/show_bug.cgi?id=37679 
In upstream bug have found that interrupts are not being generated for radeon in /proc/interrupts.

Moved from gdm back to Xorg ati component.

Comment 9 Matěj Cepl 2011-06-09 12:54:22 UTC
I agree and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for helping to make free software better.


Note You need to log in before you can comment on or make changes to this bug.