Bug 698012 - Epub build errors
Epub build errors
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: publican (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-19 18:39 EDT by Zach Oglesby
Modified: 2012-01-25 17:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-25 17:32:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use epub.embedded.fonts in epub.xsl (1.28 KB, patch)
2011-05-11 17:06 EDT, William Cohen
no flags Details | Diff

  None (edit)
Description Zach Oglesby 2011-04-19 18:39:03 EDT
Description of problem:

When trying to build an epub with publican in fedora an error occurs.

runtime error: file /usr/share/publican/xsl/epub.xsl element if
Variable 'epub.embedded.font' has not been declared.
 at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 917

Version-Release number of selected component (if applicable):
version 2.5

How reproducible:
build a doc with format=epub
Comment 1 William Cohen 2011-05-03 10:09:15 EDT
Didn't see this problem on RHEL-6 machine with:

publican-2.5-1.el6.x86_64
publican-redhat-2.7-1.el5.noarch
publican-doc-2.5-1.el6.x86_64
publican-fedora-1.7-0.el5.noarch
Comment 2 William Cohen 2011-05-11 17:02:50 EDT
After installing docbook-style-xsl-1.76.1-2.fc15.noarch.rpm on previously working RHEL-6 machine now see:

runtime error: file /usr/share/publican/xsl/epub.xsl element if
Variable 'epub.embedded.font' has not been declared.
 at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 917

comparing the versions of the code see:

--- docbook-style-xsl-1.75.2-6.el6.noarch/usr/share/sgml/docbook/xsl-stylesheets
-1.75.2/epub/docbook.xsl	2010-05-04 09:32:45.000000000 -0400
+++ docbook-style-xsl-1.76.1-2.fc15.noarch/usr/share/sgml/docbook/xsl-stylesheet
s-1.76.1/epub/docbook.xsl	2011-02-08 09:44:18.000000000 -0500
...
-  <xsl:param name="epub.embedded.font"></xsl:param>
+  <xsl:param name="epub.embedded.fonts"></xsl:param>

Found that making a similar change in /usr/share/publican/xsl/epub.xsl allowed things to work.
Comment 3 William Cohen 2011-05-11 17:06:20 EDT
Created attachment 498401 [details]
Use epub.embedded.fonts in epub.xsl

Seems that docbook-style-xsl-1.76.1-2 uses "epub.embedded.fonts" rather than "epub.embedded.font". This patch matches publican up with that change.
Comment 4 William Cohen 2011-05-11 18:09:41 EDT
Looks like there have been some changes in the upstream pulibcan related to this:

https://fedorahosted.org/publican/changeset/1748
Comment 5 William Cohen 2012-01-25 17:32:11 EST
This now works in Fedora-15 and Fedora-16 which have docbook-style-xsl-1.76.1-2.fc15.noarch

Note You need to log in before you can comment on or make changes to this bug.