Bug 69802 - Shutdown hangs on NFS unmount if server not there
Summary: Shutdown hangs on NFS unmount if server not there
Status: CLOSED DUPLICATE of bug 63602
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-25 15:42 UTC by Jeremy Sanders
Modified: 2014-03-17 02:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Sanders 2002-07-25 15:42:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
We have a server machine on a UPS, using autofs and nfs to mount home
directories on other machines. The server cannot shutdown properly (takes at
least an hour in tests) if it cannot talk to the machines which it has mounted
nfs directories from.

This happens if the network goes out (due to a power cut), or if one of the
machines acting as an nfs server was shut down.

This means it never gets to unmount its local raid hard disks before the ups
runs out of power, which is pretty bad.

Looking at the initscript, it should try three times to unmount nfs systems,
killing processes using them between each time. It seems to hang after the first
[failed].


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Mount remote nfs directory
2. cd to directory
3. Disconnect network
4. Initiate shutdown from another console
	

Actual Results:  The machine never gets to shut down. Messages such as

nfs: server xpc1.blah.blah not responding, still trying
cannot MOUNTPROG RPC: RPC: Port mapper failure - RPC: Unable to receieve
umount2: Device or resource busy
umount: /data/gm: device is busy


Expected Results:  The machine should give up trying to unmount remote
filesystems if the network isn't there. It is important to shut down in a
reasonable time period (especially if it running on a UPS).

A workaround may be to only try to unmount the filesystems once. It would be
good to have a timeout of a couple of minutes.

Additional info:

Remote nfs mounts are mounted with:
rw,v3,rsize=4096,wsize=4096,hard,intr,udp,lock

Comment 1 Jeremy Sanders 2002-07-26 08:26:21 UTC
Tests indicate (by commenting out various lines) that it is the fuser command
which hangs. Commenting out this line allows the shutdown to proceed.

Comment 2 Alexandre Oliva 2003-02-22 04:39:21 UTC

*** This bug has been marked as a duplicate of 63602 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:49:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.