This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 698026 - Python Client support for software translation projects (Gettext/PO)
Python Client support for software translation projects (Gettext/PO)
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: Sprint-23
: ---
Assigned To: James Ni
Ding-Yi Chen
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-19 21:10 EDT by Sean Flanigan
Modified: 2011-10-27 00:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-27 00:29:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-04-19 21:10:47 EDT
We need support for pushing and pulling PO-based software translation projects.  

Whereas publican projects have multiple POT files (chapter1.pot, chapter2.pot, etc) and one directory per locale (fr/, de/), software/xgettext projects generally have one POT file (myprogram.pot) and one PO file per locale (fr.po, de.po), usually in the same directory.
Comment 1 James Ni 2011-04-28 03:06:13 EDT
I have build a new package,version 1.2.3, for python-client, it includes software projects support. And it has pushed to fedora updates for Fedora13, 14, and 15, also Epel5, and 6. 

There are two issues left for software projects support:
1)--dir option for pushing source files to server
2)rhbz#696474 python client should only delete files from server which no longer exist on client. This feature didn't implement for software projects, since most of the software projects have one POT file.
Comment 2 Ding-Yi Chen 2011-05-23 00:06:22 EDT
Please make sure you fill the Bug number whenever you submit your update to fedora.

Note You need to log in before you can comment on or make changes to this bug.