Bug 698028 - Support .po file as a source for software translation projects
Support .po file as a source for software translation projects
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Ni
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-19 21:20 EDT by Sean Flanigan
Modified: 2012-01-03 21:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-03 21:57:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-04-19 21:20:01 EDT
Some software projects may name the POT file as if it were a PO file, because the default output of the xgettext command is messages.po.  We should handle this.

Some examples: http://www.google.com/codesearch?hl=en&lr=&q=file%3A^.*%2Fmessages.po%24&sbtn=Search
Comment 2 James Ni 2011-04-21 03:22:12 EDT
I have add a command line option named --srcfile, for software projects may name the POT file as a PO file, you could use this option as below:

1)zanata po push --srcfile="path to po file"

2)You could also make the PO file name as a command arguments and specify the source folder for looking up:
zanata po push "pofilename" --srcdir="path to folder contain po file"

the changes is in commit d52f339 and commit 300de0d, please use commit d52f339 of devel branch of zanataclient on github for test.

Best Regards

Note You need to log in before you can comment on or make changes to this bug.