Bug 69805 - problems and errors registering with up2date
problems and errors registering with up2date
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks: 67217 79578
  Show dependency treegraph
 
Reported: 2002-07-25 11:59 EDT by Need Real Name
Modified: 2015-01-07 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-09 08:46:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-25 11:59:53 EDT
Description of Problem:
Don't seem to be able to register and get updates using up2date. Also noticed
some errors being displayed on the console.

Version-Release number of selected component (if applicable):
up2date-2.9.27-7.x.9
up2date-gnome-2.9.27-7.x.9


How Reproducible:
Everytime

Steps to Reproduce:
1. run up2date
2. 
3. 

Actual Results:
System wasn't registered and errors seem on console.

Expected Results:
System registered, updates identified, no errors on console.


Additional Information:

Displaying the first "page" resulted in the following warning being displayed on
the console:

** (up2date:1608): WARNING **: could not find handler `onRegPackagePageBack'

Displaying the privacy page, saw the following warnings:

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 361, in onPrivacyPagePrepare
   except rhnreg.CommunicationError, e:
AttributeError: 'module' object has no attribute 'CommunicationError'

and also, no privacy statement could be seem - the box was completely empty.

Entering an (already existing) username and password, saw the following traceback:

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 414, in onInfoPageNext
    except rhnreg.ValidationError, e:
AttributeError: 'module' object has no attribute  'ValidationError'

Clicked forward to skip personal details entry, then forward again to select
system details to send. System displays "Send installed RPM list" page (Stage
3). Warning on console:

TypeError: hide() takes no arguments (1 given)

Keep clicking forward, system tells you it is sending details to RHN, then get:

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 740, in onSendPageNext
    except rhnreg.CommunicationError, e:
AttributeError: 'module' object has no attribute 'CommunicationError'
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1156, in onChannelsPagePrepare
    except up2dateErrors.CommunicationsError, e:
AttributeError: 'module' object has no attribute 'CommunicationsError'


on the console.


System never seems to "recover". Left it for 20 minutes, nothing seems to
happen. No machine is associated with the already created (via the website)
profile. The GUI and the progress bar just stay on screen, no updates are ever
seen on the progress bar.

process was then killed.
Comment 1 Need Real Name 2002-07-25 15:11:51 EDT
Same problems occur in up2date-2.9.28.
Comment 2 Adrian Likins 2002-07-25 19:17:47 EDT
yup, moved the rhnreg.*Errors to up2dateErrors and
missed updating the code in gui.py to look for them there.

Should be fixed in 2.9.28 or higher.
Comment 3 Adrian Likins 2002-07-25 19:18:14 EDT
er, make that "should be fixed in version 2.9.29 or higher"
Comment 4 Need Real Name 2002-08-05 04:01:51 EDT
Seems to be ok now in Limbo beta 2.
Comment 5 Douglas Kilpatrick 2002-08-18 21:37:01 EDT
I'm getting basically the same problem with up2date as in limbo2 or the 
2.9.46-1 in rawhide.
Comment 6 Michael Schwendt 2002-09-05 19:28:32 EDT
Can't reproduce these symptoms anymore with up2date-2.9.68-1 from (null) updates.
Comment 7 Jay Turner 2003-01-09 08:46:01 EST
Closing this out on confirmation from reporter.

Note You need to log in before you can comment on or make changes to this bug.