Bug 698134 - nut has dependency on HAL
nut has dependency on HAL
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 05:34 EDT by Alan Pevec
Modified: 2011-05-30 02:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: nut-2.6.0-5.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-20 10:53:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2011-04-20 05:34:54 EDT
Description of problem:
nut has dependency on hal which got removed in f16 rawhide:
> DEBUG util.py:247:  ERROR with rpm_check_debug vs depsolve:
> DEBUG util.py:247:  hal is needed by nut-client-2.6.0-4.fc16.x86_64


Version-Release number of selected component (if applicable):
nut-2.6.0-4.fc16

How reproducible:
Build a package in koji target dist-f16 with BuildRequires: nut-devel
e.g. collectd
Comment 1 Alan Pevec 2011-04-20 06:13:21 EDT
Example failed collectd build:
http://koji.fedoraproject.org/koji/getfile?taskID=3013162&name=root.log
Comment 2 Michal Hlavinka 2011-04-20 06:20:15 EDT
thanks for reporting this, I will look at it soon
Comment 3 Michal Hlavinka 2011-04-20 07:15:44 EDT
I got another complain about nut and hal, so after bumping priority - it should be fixed now. AFAIK rawhide should be enough, right? There is another bug in nut - hal relationship. Only nut-hal should require hal, not nut nor nut-client. I've fixed it in F14 and F15 (building right now)
Comment 4 Alan Pevec 2011-04-20 10:07:01 EDT
(In reply to comment #3)
> I got another complain about nut and hal, so after bumping priority - it should
> be fixed now. AFAIK rawhide should be enough, right?

yes, but now we have another issue:

DEBUG util.py:247:  Error in PREIN scriptlet in rpm package nut-client-2.6.0-5.fc16.i686
DEBUG util.py:247:  usermod: group 'dialout' does not exist
DEBUG util.py:247:  error: %pre(nut-client-2.6.0-5.fc16.i686) scriptlet failed, exit status 6
DEBUG util.py:247:  error:   install: %pre scriptlet failed (2), skipping nut-client-2.6.0-5.fc16

https://koji.fedoraproject.org/koji/getfile?taskID=3013805&name=root.log
Comment 5 Michal Hlavinka 2011-04-20 10:30:14 EDT
this is different bug

group dialout is(was?) managed by udev. In oooold Fedora versions it was group 'uucp' I guess they changed the name again. It should be quick fix, so just a sec ;)
Comment 6 Michal Hlavinka 2011-04-20 10:53:55 EDT
It was caused by this change. udev is required, but because there is no explicit requirement, it can be added after nut, which is too late. I've added explicit requirement to spec file. It should fix this problem
Comment 7 Alan Pevec 2011-04-20 12:07:30 EDT
yep, it worked, thanks!
https://koji.fedoraproject.org/koji/buildinfo?buildID=239807
Comment 8 Jordan Russell 2011-05-21 00:33:32 EDT
(In reply to comment #3)
> Only nut-hal should require hal, not nut nor
> nut-client. I've fixed it in F14 and F15 (building right now)

In nut-2.6.0-5.fc14, a "pre" dependency on hal still exists in the nut-client and nut-cgi subpackages:
Requires(pre): /usr/sbin/useradd hal

This is causing "rpm -Va" to complain:

Unsatisfied dependencies for nut-client-2.6.0-5.fc14.i686:
	hal is needed by nut-client-2.6.0-5.fc14.i686
Comment 9 Michal Hlavinka 2011-05-23 05:03:28 EDT
fixed in nut-2.6.0-7.fc14
Comment 10 Jordan Russell 2011-05-28 00:13:46 EDT
(In reply to comment #9)
> fixed in nut-2.6.0-7.fc14

Thanks. Will the same change be made on the f15 branch? (I don't see it in gitweb.)
Comment 11 Michal Hlavinka 2011-05-30 02:49:26 EDT
That's odd, this is second time it went wrong - I had these changes in f13 branch (files from f15 replaced all f13 files), but luckily it was not pushed. I wonder what happened (maybe caused by origin/fX -> fX change, don't know). Anyway, fixed now. Just committed, no build this time, because there will be 2.6.1 bugfix release soon.

Note You need to log in before you can comment on or make changes to this bug.