Bug 698199 - Can not assign a static iP in F15's NetworkManager
Summary: Can not assign a static iP in F15's NetworkManager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 692676 697700 698379 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-20 12:35 UTC by Kenny Armstrong
Modified: 2011-08-12 18:23 UTC (History)
6 users (show)

Fixed In Version: NetworkManager-0.8.4-2.git20110622.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-10 03:25:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 607678 None None None Never

Description Kenny Armstrong 2011-04-20 12:35:04 UTC
Description of problem:

Can not assign a static IP to a system in NetworkManager through the Edit Connections Option for an IPv4 configuration.

Version-Release number of selected component (if applicable):
NetworkManager-0.8.998-3.git20110419.fc15.x86_64
NetworkManager-vpnc-0.8.998-1.git20110405.fc15.x86_64
NetworkManager-openvpn-0.8.998-1.git20110405.fc15.x86_64
NetworkManager-gnome-0.8.998-3.git20110419.fc15.x86_64
NetworkManager-pptp-0.8.998-1.fc15.x86_64
NetworkManager-glib-0.8.998-3.git20110419.fc15.x86_64


How reproducible:


Steps to Reproduce:
1. Right click on NetworkManager, choose 'Edit Connections'
2. Highlight the wired connection, and click the Edit button
3. Click on the IPv4 tab, and change the Method dropdown to Manual
4. Click the Add button, and enter in the necessary IP information
  
Actual results:
when you enter in an IP in the Address, or the Netmask or anything, when you click on the next field whatever you just entered will disappear


Expected results:
The IP information should not vanish when you move to the next field.

Additional info:

I am doing this on an XFCE desktop, as the NetworkManager in GNOME 3 is far too crippled for our setup.

Comment 1 Juan Francisco Fernández 2011-04-20 15:29:11 UTC
Hi Kenny Armstrong, don't click on other field but press Enter.

But I think there is a bug in this behavior, because I don't point any reason to erase the field if you don't press return.

Comment 2 Jirka Klimes 2011-04-29 13:24:39 UTC
This is now fixed upstream in master branch:

57ebc568daa3a4ee3cd7bbb85fddc69ffee8d424 (master)

A fix for 0.8.x will follow.

Summary of the updated behaviour:
* Tab key can be used to cycle through cells (as well as Up/Down arrows and
  Enter)
* mouse click can be used to switch between cells
* Esc can be used to leave cell (as well as clicking another part of treeview
  or another widget)
* the new edited value is stored on all ways of leaving the cell

Some notes:
GtkTreeView behaves differently for GTK2/GTK3, which is nuisance. Moreover that's not documented anywhere, so one can't know whether the changes are intended or a bug fix from the previous version or a new bug introduced.
The main change appears to be that mouse clicks outside a cell leaves the cell without editing-canceled or editing-done signals issued and thus the value is lost.
Also, there are changes in functions setting background colours for a cell and possibly others. Not documented, sigh.

Comment 3 Jirka Klimes 2011-04-29 13:25:56 UTC
*** Bug 697700 has been marked as a duplicate of this bug. ***

Comment 4 Jirka Klimes 2011-04-29 13:26:56 UTC
*** Bug 698379 has been marked as a duplicate of this bug. ***

Comment 5 Jirka Klimes 2011-04-29 13:27:38 UTC
*** Bug 692676 has been marked as a duplicate of this bug. ***

Comment 6 Jirka Klimes 2011-05-03 08:45:27 UTC
Fix for 0.8.x:
7bbd61a2744cceb38a9a04460e21ddef8df76999

Comment 7 Fedora Update System 2011-05-04 05:28:48 UTC
NetworkManager-0.8.999-1.fc15,NetworkManager-openswan-0.8.999-1.fc15,NetworkManager-openconnect-0.8.999-1.fc15,NetworkManager-pptp-0.8.999-1.fc15,NetworkManager-openvpn-0.8.999-1.fc15,NetworkManager-vpnc-0.8.999-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.999-1.fc15,NetworkManager-openswan-0.8.999-1.fc15,NetworkManager-openconnect-0.8.999-1.fc15,NetworkManager-pptp-0.8.999-1.fc15,NetworkManager-openvpn-0.8.999-1.fc15,NetworkManager-vpnc-0.8.999-1.fc15

Comment 8 Fedora Update System 2011-05-05 04:45:02 UTC
Package NetworkManager-0.8.999-1.fc15, NetworkManager-openswan-0.8.999-1.fc15, NetworkManager-openconnect-0.8.999-1.fc15, NetworkManager-pptp-0.8.999-1.fc15, NetworkManager-openvpn-0.8.999-1.fc15, NetworkManager-vpnc-0.8.999-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.999-1.fc15 NetworkManager-openswan-0.8.999-1.fc15 NetworkManager-openconnect-0.8.999-1.fc15 NetworkManager-pptp-0.8.999-1.fc15 NetworkManager-openvpn-0.8.999-1.fc15 NetworkManager-vpnc-0.8.999-1.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.999-1.fc15,NetworkManager-openswan-0.8.999-1.fc15,NetworkManager-openconnect-0.8.999-1.fc15,NetworkManager-pptp-0.8.999-1.fc15,NetworkManager-openvpn-0.8.999-1.fc15,NetworkManager-vpnc-0.8.999-1.fc15
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-05-10 03:24:54 UTC
NetworkManager-0.8.999-1.fc15, NetworkManager-openswan-0.8.999-1.fc15, NetworkManager-openconnect-0.8.999-1.fc15, NetworkManager-pptp-0.8.999-1.fc15, NetworkManager-openvpn-0.8.999-1.fc15, NetworkManager-vpnc-0.8.999-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-06-22 18:56:08 UTC
NetworkManager-0.8.4-2.git20110622.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.4-2.git20110622.fc14

Comment 11 Fedora Update System 2011-08-12 10:53:26 UTC
NetworkManager-0.8.4-2.git20110622.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-08-12 18:22:59 UTC
NetworkManager-0.8.4-2.git20110622.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.