Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 698208

Summary: libvirtd cannot start on s390x machine
Product: Red Hat Enterprise Linux 6 Reporter: Milos Malik <mmalik>
Component: libvirtAssignee: Michal Privoznik <mprivozn>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: berrange, dallan, dyuan, eblake, mzhan, yoyzhang
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: s390x   
OS: Linux   
Whiteboard:
Fixed In Version: libvirt-0.9.1-1.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-06 11:05:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 675698    
Bug Blocks:    

Description Milos Malik 2011-04-20 12:45:05 UTC
Description of problem:


Version-Release number of selected component (if applicable):
libpciaccess-0.10.9-4.el6.s390x
libvirt-0.8.7-18.el6.s390x
libvirt-client-0.8.7-18.el6.s390x
libvirt-devel-0.8.7-18.el6.s390x
libvirt-java-0.4.7-1.el6.noarch
libvirt-java-devel-0.4.7-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
# rpm -V libpciaccess
# rpm -V libvirt
# service cgconfig status
Running
# service libvirtd status
libvirtd is stopped
# service libvirtd start
Starting libvirtd daemon: [  OK  ]
# service libvirtd status
libvirtd dead but subsys locked
# service libvirtd restart
Stopping libvirtd daemon: [FAILED]
Starting libvirtd daemon: [  OK  ]
# service libvirtd status
libvirtd dead but subsys locked
# 

Actual results (seen in /var/log/messages):
Apr 20 08:46:01 ibm-z10-27 libvirtd: 08:46:01.249: 50897: info : libvirt version
: 0.8.7, package: 18.el6 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2011-04-18-10:28:07, s390-009.build.bos.redhat.com)
Apr 20 08:46:01 ibm-z10-27 libvirtd: 08:46:01.249: 50897: error : udevDeviceMonitorStartup:1606 : Failed to initialize libpciaccess: No such file or directory
Apr 20 08:46:01 ibm-z10-27 libvirtd: 08:46:01.254: 50897: error : virStateInitialize:1022 : Initialization of udev state driver failed
Apr 20 08:46:02 ibm-z10-27 kernel: lo: Disabled Privacy Extensions
Apr 20 08:46:02 ibm-z10-27 libvirtd: 08:46:02.510: 50897: error : main:3326 : Driver state initialization failed
Apr 20 08:46:02 ibm-z10-27 libvirtd: 08:46:02.514: 50899: warning : qemudDispatchSignalEvent:403 : Shutting down on signal 3
Apr 20 08:46:13 ibm-z10-27 libvirtd: 08:46:13.293: 50967: info : libvirt version: 0.8.7, package: 18.el6 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2011-04-18-10:28:07, s390-009.build.bos.redhat.com)
Apr 20 08:46:13 ibm-z10-27 libvirtd: 08:46:13.293: 50967: error : udevDeviceMonitorStartup:1606 : Failed to initialize libpciaccess: No such file or directory
Apr 20 08:46:13 ibm-z10-27 libvirtd: 08:46:13.293: 50967: error : virStateInitialize:1022 : Initialization of udev state driver failed
Apr 20 08:46:13 ibm-z10-27 kernel: lo: Disabled Privacy Extensions
Apr 20 08:46:13 ibm-z10-27 libvirtd: 08:46:13.410: 50967: error : main:3326 : Driver state initialization failed
Apr 20 08:46:13 ibm-z10-27 libvirtd: 08:46:13.410: 50969: warning : qemudDispatchSignalEvent:403 : Shutting down on signal 3

Expected results:
libvirtd can be started

Comment 1 Michal Privoznik 2011-04-21 08:35:58 UTC
*** Bug 698539 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Berrangé 2011-04-21 09:14:33 UTC
Can you confirm that this worked successfully on 6.0, and if so mark this as a regression.

Comment 3 Milos Malik 2011-04-21 09:50:41 UTC
[root@ibm-z10-05 ~]# service libvirtd status
libvirtd is stopped
[root@ibm-z10-05 ~]# service libvirtd start
Starting libvirtd daemon: [  OK  ]
[root@ibm-z10-05 ~]# service libvirtd status
libvirtd (pid  34550) is running...
[root@ibm-z10-05 ~]# service libvirtd stop
Stopping libvirtd daemon: [  OK  ]
[root@ibm-z10-05 ~]# service libvirtd status
libvirtd is stopped
[root@ibm-z10-05 ~]# grep RHEL /etc/motd
                           DISTRO=RHEL6-6.0
[root@ibm-z10-05 ~]# rpm -qa libvirt\*
libvirt-devel-0.8.1-27.el6.s390x
libvirt-0.8.1-27.el6.s390x
libvirt-client-0.8.1-27.el6.s390x
libvirt-java-0.4.5-2.el6.noarch
libvirt-java-devel-0.4.5-2.el6.noarch
[root@ibm-z10-05 ~]# grep libvirt /var/log/messages 
Apr 21 05:49:26 ibm-z10-05 libvirtd: 05:49:26.053: error : udevGetDMIData:1483 : Failed to get udev device for syspath '/sys/devices/virtual/dmi/id' or '/sys/class/dmi/id'
Apr 21 05:49:26 ibm-z10-05 libvirtd: 05:49:26.260: error : virNWFilterRuleDetailsParse:1357 : internal error protocolid has illegal value 0x835
Apr 21 05:49:26 ibm-z10-05 libvirtd: 05:49:26.469: warning : lxcStartup:1884 : Unable to create cgroup for driver: No such device or address
Apr 21 05:49:34 ibm-z10-05 libvirtd: 05:49:34.156: warning : qemudDispatchSignalEvent:392 : Shutting down on signal 15
[root@ibm-z10-05 ~]# 

I believe it is a regression. libvirt daemon can be started on s390x machine with RHEL-6.0.

Comment 5 Michal Privoznik 2011-05-03 11:55:07 UTC
Pushed:

commit a2eab0033c6118e8b0a4fe47cf1aeaf4707a71a9
Author: Michal Privoznik <mprivozn>
Date:   Fri Apr 22 14:24:54 2011 +0200

    Fix disability to run on systems with no PCI bus
    
    The patch which moved libpciaccess initialization to one place caused
    regression - we were not able to run on system with no PCI bus, like
    s390(x).

v0.9.0-194-ga2eab00

Comment 6 Eric Blake 2011-05-03 13:53:50 UTC
Regression introduced in bug 675698

Comment 7 zhanghaiyan 2011-05-25 09:02:37 UTC
Reproduced the bug with libvirt-0.8.7-18.el6.s390x 
(totally the same other packages, test step and actual result)

Verified pass with libvirt-0.9.1-1.el6.s390x
.qa.[root@s390x-6s-v1 ~]# rpm -V libpciaccess
.qa.[root@s390x-6s-v1 ~]# rpm -V libvirt
.qa.[root@s390x-6s-v1 ~]# service cgconfig status
Running
.qa.[root@s390x-6s-v1 ~]# service libvirtd status
libvirtd (pid  13459) is running...
.qa.[root@s390x-6s-v1 ~]# virsh list 
 Id Name                 State
----------------------------------

.qa.[root@s390x-6s-v1 ~]# service libvirtd restart
Stopping libvirtd daemon: [  OK  ]
Starting libvirtd daemon: [  OK  ]
.qa.[root@s390x-6s-v1 ~]# service libvirtd status
libvirtd (pid  13617) is running...
.qa.[root@s390x-6s-v1 ~]# virsh list 
 Id Name                 State
----------------------------------

Comment 9 Min Zhan 2011-07-18 07:22:04 UTC
Move to VERIFIED according to Comment 7

Comment 10 errata-xmlrpc 2011-12-06 11:05:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html