Bug 698217 - Exportfs Resource Agent fails to start when clientspec="*"
Exportfs Resource Agent fails to start when clientspec="*"
Status: CLOSED DUPLICATE of bug 707127
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 09:02 EDT by bcodding
Modified: 2011-11-10 08:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 12:17:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch that properly escapes an "*" in clientspec. (612 bytes, text/plain)
2011-04-20 09:02 EDT, bcodding
no flags Details

  None (edit)
Description bcodding 2011-04-20 09:02:31 EDT
Created attachment 493480 [details]
A patch that properly escapes an "*" in clientspec.

The exportfs resource agent (ocf:heartbeat:exportfs) fails to start when the clientspec param is set to "*", reporting:

exportfs[23964]: INFO: Exporting file system ...
exportfs[23964]: ERROR: Export not reported by showmount -e

This is because the * is not properly escaped in /usr/lib/ocf/resource.d/heartbeat/exportfs:142.

Name        : resource-agents
Version     : 3.0.12         
Release     : 15.el6_0.1     

Easily reproduced by adding a new exportfs on a valid cluster:

crm configure primitive NFS_EXPORT ocf:heartbeat:exportfs params clientspec="*" options="" directory="/exports" fsid="100"

Attached a patch that properly escapes an "*" in clientspec.
Comment 6 Chris Feist 2011-07-21 12:17:19 EDT
This has been fixed as part of the resource agent rebase, marking as duplicate.

*** This bug has been marked as a duplicate of bug 707127 ***

Note You need to log in before you can comment on or make changes to this bug.