Bug 6983 - Severely broken documentation files
Severely broken documentation files
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: howto (Show other bugs)
6.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-12 22:56 EST by Oliver Richman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-09 13:07:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Richman 1999-11-12 22:56:10 EST
Dear Sir;

3 problems here. 1. HOWTOs, 2. the desktop help systems, and 3.lots of
errors in printed manuals (I would love to help fix them!)

1. HOWTOs
  In reading over several of the HOWTOs, most notably the ISP-Hookup-HOWTO
and the Chinese-HOWTO, and others, it struck me that not only is the
information extremely out of date (by a couple of YEARS in some cases) but
better programs exist than the ones they describe. Even worse, some HOWTOs
describe the use of software and techniques that DO NOT WORK under RedHat
6.1. An example is in the ISP-Hookup-HOWTO, the author describes (in
norwegian english ^^) that the user must check the file
"/var/adm/messages". In RedHat 6.1 this is actually /var/log/messages.

I know that RedHat is not responsible for maintaining these lists. However,
I think it's irresponsible to include them with RedHat 6.1 if they are so
severely outdated.

I'm going to be contacting the maintainers of these lists, because if some
of them are no longer being maintained, someone should a) fix them, or b)
take over the maintenance permanently.

2. desktop help systems.
RedHat 6.1 includes a file configured to run with the gnome or kde help
utility. It links to the man pages and to the info files (GREAT!!!) but it
doesen't link to the HOWTOs!!!!!!!!!!!!!!!!!!! I was so suprised.
Especially since there's a HTML index installed by RedHat 6.1 for the
HOWTOs. Should we add this manually?

3. Errors in Documentation
Errors such as accidentally saying "Chinese-HOWTO" in the "Croatian-HOWTO"
section (or whatever) to other spelling and typesetting errors make reading
the reference and installation guides an adventure. If no one else has time
to maintain them (Other things are more important actually), I would LOVE
to help out in a small way and fix those problems. I have an excellent
command of the english language when I want.. and this seems like a good
way to put it to use.

Oops, #4: Incomplete system requirements on Boxed Sets
You should inform users that they cannot use PCI "modems" on the system
box. I feel you must do this, as I had to buy a new external modem. You
should point out to them somehow that they can buy cheap external 56k
modems from a number of sources, and it won't cost more than the $50 they
paid for the boxed set.

Anyways, you guys are doing a GREAT job.. But I have one suggestion..
Please contribute to the stability of GNOME and KDE, and also contribute to
the ease of use and power of these environments. Already everyone in my
office is impressed with my switch to Linux, although my boss said we won't
do a complete switchover until after a few months of "working it in".

You guys have done a hell of a lot for the Linux community, thank you.
Comment 1 Trond Eivind Glomsrxd 2000-04-09 13:07:59 EDT
The HOW-TOs are produced by the Linux Documentation Project - LDP
(.http://www.linuxdoc.org/) If some of them are old and outdated (as opposed to
just old), you should contact them or the authors of the respective HOW-TOs.

The GNOME help system is just that - a help system for GNOME. There are
currently no integrated system of GNOME, KDE, HOW-TOs etc (but I'd love having
one).

If you find errors in the RH install guide, reference guid etc, file that
separately to get it fixed (be as concrete as possi

Note You need to log in before you can comment on or make changes to this bug.