Bug 698314 - need to hit refresh button to see recent operations
need to hit refresh button to see recent operations
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta1
Unspecified Unspecified
medium Severity high (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-20 11:43 EDT by John Mazzitelli
Modified: 2011-05-23 21:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-04-20 11:43:04 EDT
I go to Report>Recent Operations and I see an empty table (even though I know I recently executed some operations). So I click the "refresh" button and the table finally populates with the data.
Comment 1 Charles Crouch 2011-04-20 12:07:57 EDT
Don't think this is as high a priority as other issues.
Comment 2 John Mazzitelli 2011-04-20 12:28:07 EDT
I made this a high priority because this may be a canary-in-the-mine - this is not the first time I saw behavior like this, so this could be an indication of a wider problem across the board. We need to look at the Table implementation that changed recently (re: initial criteria/fixed criteria) and make sure either a) nothing is broken or b) we need subclasses to use the new initial criteria feature.

In other words, this is more than just a bug in Reports>Recent Operations, we need to investigate if the underlying Table component implementation and its usages are broken in other places.
Comment 3 Jay Shaughnessy 2011-04-21 10:01:55 EDT
commit 73c089cea2df5f4bcb4820dd0a831636cc9c4d5e
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Thu Apr 21 09:59:45 2011 -0400

    An async issue that could result in the totalRows of a fetch not being
    initialized (and therefore set to 0).  The fetch itself was successful, but
    the Response was wrong if the timing was right.
Comment 4 Sunil Kondkar 2011-04-27 05:28:54 EDT
Verified on build#28 (Version: 4.0.0-SNAPSHOT Build Number: da7bcb0)

Executed some operations on a resource and verified that the Report>Recent Operations page displays the recent operations without hitting the Refresh button.

Marking as verified.
Comment 5 Corey Welton 2011-05-23 21:10:44 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:10:49 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.