Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 698346 - [saz_IN] Locale definition file for Sourashtra is not available
[saz_IN] Locale definition file for Sourashtra is not available
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 13:24 EDT by Santhosh Thottingal
Modified: 2016-11-24 10:58 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-07 03:52:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
saz_IN locale definition file (6.37 KB, text/plain)
2011-04-22 10:12 EDT, Santhosh Thottingal
no flags Details
saz_IN locale definition file with Rupee symbol (6.36 KB, text/plain)
2011-09-06 11:03 EDT, Santhosh Thottingal
no flags Details

  None (edit)
Description Santhosh Thottingal 2011-04-20 13:24:57 EDT
Description of problem:

The Locale file for Sourashtra (http://en.wikipedia.org/wiki/Sourashtra) is  not available in glibc, which prevents the i18n and l10n activities for the language. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Santhosh Thottingal 2011-04-22 10:12:00 EDT
Created attachment 494229 [details]
saz_IN locale definition file

This is the glibc locale definition file for Sourashtra prepared with the help of Prabu M Rangachari.
Comment 2 Pravin Satpute 2011-04-28 06:53:35 EDT
localedef -i ./saz_IN -f UTF-8 ./saz_TT works fine with this locale.

Since we are pushing this in glibc i think better to use New INR Symbol.
U+20B9 as a currency symbol.

But somehow this is not working presently.

I have reported bug upstream http://sourceware.org/bugzilla/show_bug.cgi?id=12711
Comment 3 Santhosh Thottingal 2011-09-06 11:03:03 EDT
Created attachment 521683 [details]
saz_IN locale definition file with Rupee symbol

Modified the  locale definition file with Rupee symbol.
Comment 4 Pravin Satpute 2011-09-07 03:52:23 EDT
Hi Santhosh,

We are lucky this time, this locale is already committed in upstream with INR symbol, i think it will be available with next upstream release
see http://sourceware.org/bugzilla/show_bug.cgi?id=12711

Thanks for your input, still we have to create locales for Bodo, Santhali, Dogri one of the official 22 languages 

Closing bug, kindly reopen if any problem

Note You need to log in before you can comment on or make changes to this bug.