Bug 698439 - Wrong use of memcpy in zsh
Wrong use of memcpy in zsh
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 696096
  Show dependency treegraph
 
Reported: 2011-04-20 17:33 EDT by Felipe Contreras
Modified: 2012-02-02 16:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-02 16:55:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Felipe Contreras 2011-04-20 17:33:05 EDT
Description of problem: zsh uses memcpy wrongly

Version-Release number of selected component (if applicable): 4.3.10-5

Follow the instructions in parent bug #696096.

Paste the following into the command line:

foo:            baaaaaaaaaaaaaaaaaaaaaaaaaar
foo:            baaaaaaaaaaaaaaaaaaaaaaaaaar
foo:            baaaaaaaaaaaaaaaaaaaaaaaaaar

A crash occurs.
Comment 1 Dominic Hopf 2011-12-17 14:01:27 EST
Trying to reproduce the issue with the instructions you described 696096 is not causing a crash anymore, unfortunately. I was able to point out lines like this in /var/log/messages instead:

Dec 17 19:56:21 hellraiser ksmtuned[1127]: ERROR: ld.so: object '/tmp/memcpy_check.so' from /etc/ld.so.preload cannot be preloaded: ignored.


For the record: I have an F16 installation here and run Zsh version 4.3.14 which is available in updates-testing.


Is there any other way to maybe reproduce this issue or can we assume this has been fixed in the meanwhile?
Comment 2 Felipe Contreras 2011-12-22 11:28:25 EST
(In reply to comment #1)
> Trying to reproduce the issue with the instructions you described 696096 is not
> causing a crash anymore, unfortunately. I was able to point out lines like this
> in /var/log/messages instead:
> 
> Dec 17 19:56:21 hellraiser ksmtuned[1127]: ERROR: ld.so: object
> '/tmp/memcpy_check.so' from /etc/ld.so.preload cannot be preloaded: ignored.

You must be doing something wrong then.

Please use attachment #493497 [details].

And do this:
% gcc -O2 -fPIC -Wall -Werror memcpy_check.c --shared -o /tmp/memcpy_check.so
% echo /tmp/memcpy_check.so | sudo tee /etc/ld.so.preload

Make sure that all these commands succeed, that ld.so.preload contains /tmp/memcpy_check.so, and that 'file /tmp/memcpy_check.so' returns something that is compatible to your machine.

FTR, still crashes here.
Comment 3 Felipe Contreras 2012-02-02 16:55:38 EST
Seems to be fixed now. Maybe 4.3.14, or maybe 4.3.15.

Note You need to log in before you can comment on or make changes to this bug.