Bug 698441 - fedora-easy-karma submits too many comments to bodhi when bodhi has a server problem
fedora-easy-karma submits too many comments to bodhi when bodhi has a server ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 17:34 EDT by Christopher Aillon
Modified: 2016-09-19 22:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-25 11:54:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2011-04-20 17:34:00 EDT
Not sure if this is a fedora-easy-karma bug or a bodhi bug, but filing here for now.

I started using fedora-easy-karma and during my usage, koji went down (around Wed Apr 20 2100 UTC)

I had submitted a comment to https://admin.fedoraproject.org/updates/FEDORA-2011-5638

fedora-easy-karma told me:
Comment? -1/0/1 ->karma, other -> skip> 1
Comment> yep
Warning: Server error: ServerError(https://admin.fedoraproject.org/updates/comment, 500, Internal Server Error)
Warning: Server error: ServerError(https://admin.fedoraproject.org/updates/comment, 500, Internal Server Error)
Warning: Server error: ServerError(https://admin.fedoraproject.org/updates/comment, 500, Internal Server Error)
Warning: Server error: ServerError(https://admin.fedoraproject.org/updates/comment, 500, Internal Server Error)
Warning: Comment not submitted: too many errors


However, as you can see on the update, it actually did submit the comment each time it told me it didn't (4 in total).
Comment 1 Christopher Aillon 2011-04-20 17:45:08 EDT
<lmacken> caillon: it's due to the koji outage
<lmacken> caillon: since your comment will trigger autokarma, it errors out in adding the -pending tag to the update

Ah, so the problem is that since the package has karma automatism set to 3, and I am the 3rd +1, it failed in moving the package over to the new tag.  Not really sure how to best handle it.  Perhaps bodhi should be taken offline during future koji outages?
Comment 2 Till Maas 2011-08-19 14:13:36 EDT
I do not see what I can do here. Fedora-easy-karma allows to limit the retries in case of an error:

--retries=RETRIES     Number if retries when submitting a comment in case of
                        an error, default: 3

Use --retries=0 if you want to avoid multiple comments in all cases.
Comment 3 Luke Macken 2011-10-25 11:54:39 EDT
This issue should be resolved with bodhi v0.8.3, which is currently deployed to
production. I made the addition/removal of pending tags more robust, so future koji outages shouldn't trigger this.

Note You need to log in before you can comment on or make changes to this bug.