Bug 698520 - A possible logical error in rc.sysinit
Summary: A possible logical error in rc.sysinit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: initscripts Maintenance Team
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-21 06:04 UTC by John Lau
Modified: 2014-09-08 12:24 UTC (History)
4 users (show)

Fixed In Version: initscripts-9.03.24-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 18:09:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch of this fix (571 bytes, patch)
2011-04-21 06:05 UTC, John Lau
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1528 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2011-12-06 01:02:05 UTC

Description John Lau 2011-04-21 06:04:26 UTC
Description of problem:
We found that there is a possible logical error in the following section in rc.sysinit:

    ipaddr=
    if [ "$HOSTNAME" = "localhost" -o "$HOSTNAME" = "localhost.localdomain" ]; then 
        ipaddr=$(ip addr show to 0.0.0.0/0 scope global | awk '/[[:space:]]inet / { print gensub("/.*","","g",$2) }')
        for ip in $ipaddr ; do
            HOSTNAME=
            eval $(ipcalc -h $ipaddr 2>/dev/null)
            [ -n "$HOSTNAME" ] && { hostname ${HOSTNAME} ; break; }
        done
    fi

The "for ip in $ipaddr ; do" loop seems to eval the hostname each of the IP address obtained above and then set the hostname. But it seems that:

            eval $(ipcalc -h $ipaddr 2>/dev/null)

should be changed to:

            eval $(ipcalc -h $ip 2>/dev/null)

Because if $ipaddr have multiple IP address, ipcalc would not work properly.

Version-Release number of selected component (if applicable):
initscripts-9.03.17-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
Actually I don't know how to setup IP address in such early stage of boot. May be using kernel parameter? It need to setup more then 1 ip address to reproduce the problem.
  
Actual results:
hostname properly set

Expected results:
hostname not set and remain to be localhost

Comment 1 John Lau 2011-04-21 06:05:40 UTC
Created attachment 493707 [details]
Patch of this fix

Comment 3 RHEL Product and Program Management 2011-04-22 06:00:38 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 4 Bill Nottingham 2011-04-25 18:40:54 UTC
Fixed in upstream commit c145e81.

Comment 9 errata-xmlrpc 2011-12-06 18:09:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1528.html


Note You need to log in before you can comment on or make changes to this bug.