Bug 698556 - Bluetooth can't find any device
Bluetooth can't find any device
Status: CLOSED DUPLICATE of bug 694519
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
15
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 04:29 EDT by Pavol Celuch
Modified: 2013-01-10 01:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-18 18:06:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from bluetoohd -dn (11.55 KB, application/octet-stream)
2011-05-07 00:19 EDT, Pavol Celuch
no flags Details

  None (edit)
Description Pavol Celuch 2011-04-21 04:29:47 EDT
Description of problem:
Bluetooth appears to be running, but I can't change Visibility. And in Bluetooth settings, only Power setting is available.

Version-Release number of selected component (if applicable):
Bluetooth deamon 4.87

How reproducible:
Click on the bluetooth icon in Gnome 3.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Could't find bluetooth device.

Expected results:


Additional info:
#bluetooth -dn

bluetoothd[5617]: Bluetooth deamon 4.87
bluetoothd[5617]: src/main.c:parse_config() parsing main.conf
bluetoothd[5617]: src/main.c:parse_config() discovto=0
bluetoothd[5617]: src/main.c:parse_config() pairto=0
bluetoothd[5617]: src/main.c:parse_config() pageto=8192
bluetoothd[5617]: src/main.c:parse_config() name=%h-%d
bluetoothd[5617]: src/main.c:parse_config() class=0x000100
bluetoothd[5617]: src/main.c:parse_config() discov_interval=0
bluetoothd[5617]: src/main.c:parse_config() Key file does not have key 'DeviceID'
bluetoothd[5617]: Unable to get on D-Bus
Comment 1 Pavol Celuch 2011-04-21 04:30:56 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
HW
http://www.smolts.org/client/show/pub_a2d6d578-fda3-45f6-9f38-3902c01e70c1
Comment 2 Angel 2011-04-21 08:36:41 EDT
Problem exists in GNOME and KDE both. Tested on x86_64 and i386 System with a builtin bluetooth device (Notebook: Acer Aspire 4738Z) and USB bluetooth device (Desktop).
Comment 3 Bill Nottingham 2011-04-25 14:37:21 EDT
Deleting Technical Note field; not the right place for that. (It's in the comments now, in any case.)
Comment 4 Bill Nottingham 2011-04-25 14:37:21 EDT
Deleted Technical Notes Contents.

Old Contents:
HW
http://www.smolts.org/client/show/pub_a2d6d578-fda3-45f6-9f38-3902c01e70c1
Comment 5 Bastien Nocera 2011-05-06 13:26:47 EDT
Is bluetoothd actually running? Do you get any SELinux errors when this happens?

The bug report is lacking in details as to what problem you're facing exactly.
Comment 6 Pavol Celuch 2011-05-07 00:19:07 EDT
Created attachment 497476 [details]
output from bluetoohd -dn

Output from bluetoothd -dn , running as a root.
Comment 7 Pavol Celuch 2011-05-07 00:21:21 EDT
After fresh start bluetoothd deamon is not running and therefore bluetooth is not working. As a user I can not start deamon.

As root I started deamon with bluetootd -dn and attached output to this bug. After that bluetooth is working.
Comment 8 Pavol Celuch 2011-05-07 00:23:57 EDT
There were no SELinux errors.

I apologize for this bug, I have no idea why it wasn't working before and why I didn't try to run deamon as a root.
Comment 9 Bastien Nocera 2011-05-18 18:06:01 EDT
See also bug 695588 comment 16, as well as:
https://fedoraproject.org/wiki/Common_F15_bugs#Bluetooth_not_working_after_upgrade_to_F15_Beta

*** This bug has been marked as a duplicate of bug 694519 ***

Note You need to log in before you can comment on or make changes to this bug.