Bug 698594 - Patch view broken for patches-that-modify-a-patch
Patch view broken for patches-that-modify-a-patch
Status: CLOSED DUPLICATE of bug 554878
Product: Bugzilla
Classification: Community
Component: Attachments/Requests (Show other bugs)
3.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 06:39 EDT by Paolo Bonzini
Modified: 2014-10-12 18:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 20:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2011-04-21 06:39:32 EDT
Description of problem:
When a patch is modifying a patch, I don't see lines starting with "++" in either the Diff view, or the "Raw unified" view reachable from the diff view.

Version-Release number of selected component (if applicable):
3.6

How reproducible:
100%

Steps to Reproduce:
1. Open these URLs:
https://bugzilla.redhat.com/attachment.cgi?id=493776
https://bugzilla.redhat.com/attachment.cgi?id=493776&action=diff&context=patch&collapsed=&headers=1
https://bugzilla.redhat.com/attachment.cgi?id=493776&action=diff&context=patch&collapsed=&headers=1&format=raw
2. Search for LIBFDT_lib_VERSIONED in the first URL
3. Search for LIBFDT_lib_VERSIONED in the other two URLs
  
Actual results:
The "action=diff" URLs miss the lines that add LIBFDT_lib_VERSIONED.

Expected results:
The "action=diff" URLs shows patch contents correctly.
Comment 1 Simon Green 2012-06-20 20:43:26 EDT

*** This bug has been marked as a duplicate of bug 554878 ***

Note You need to log in before you can comment on or make changes to this bug.