Bug 6986 - rpmfind silently consults only Redhat's database
rpmfind silently consults only Redhat's database
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpmfind (Show other bugs)
6.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-13 01:20 EST by Chris Siebenmann
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-16 11:07:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Siebenmann 1999-11-13 01:20:22 EST
Although everything about the rpmfind package, right down to
the URL that 'rpm -qi rpmfind' points you at, leads one to
believe that the Redhat-packaged version of rpmfind is acting
just like the stock source from the master site. It is only
after being puzzled by it not finding contrib packages and so
on and running 'rpmfind -v -v -v <whatever>' does one discover
that Redhat has altered it to consult only a database of Red Hat's
own RPM packages (I believe official and Powertools only, but
since there's no documentation provided about this it's kind of
hard to tell).

 Although I understand why Redhat did this, I find it very annoying
that it was done without any warning or note. Anyone reading rpmfind's
documentation, and anyone knowing about it, is going to expect it to
consult rpmfind.net's RPM database, not a Red Hat one. Unless they
get suspicious, all the indication they'll ever get is rpmfind failing
to find packages.
Comment 1 Jeff Johnson 1999-11-16 11:07:59 EST
Change the configuration in /etc/rpmfind.conf.

Here's the output of "rpm -q --changelog rpmfind"

* Sat Sep 25 1999 Jeff Johnson <jbj@redhat.com>
- default www.redhat.com/RDF config file (Adrian Likins).
- recompile with rpm-3.0.3-1.
Comment 2 Daniel Veillard 2001-07-17 18:58:03 EDT
I actually added an entry about this in the rpmfind FAQ
http://rpmfind.net/linux/rpm2html/faq.html
it's item #7 

Sounds reasonable to close this bug now

Daniel

Note You need to log in before you can comment on or make changes to this bug.