Bug 698618 - option --no-overwrite-dir is present but not documented in manpage
option --no-overwrite-dir is present but not documented in manpage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tar (Show other bugs)
5.6
All All
low Severity low
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 07:49 EDT by Gianluca Cecchi
Modified: 2013-04-12 16:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, the option "--no-overwrite-dir" was not documented in the tar(1) manual page. This problem has been corrected so that the option is now properly documented.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-13 22:20:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch adding the option into tar RHEL-5 manpage (556 bytes, patch)
2011-06-29 10:03 EDT, Ondrej Vasik
no flags Details | Diff

  None (edit)
Description Gianluca Cecchi 2011-04-21 07:49:50 EDT
Description of problem:
the commands
man tar 
tar --help
don't show the option "--no-overwrite-dir"
but it is implememted into the command...

Version-Release number of selected component (if applicable):
1.15.1-30.el5

How reproducible:
Always

Steps to Reproduce:
1. run "man tar" or "tar --help"
2. search for --no-overwrite-dir and you don't find it
3. run the command 
tar -xv --no-overwrite-dir -f test.tar
  
Actual results:

The command will succeed

Expected results:

Failure of command or update of man and --help option

Additional info:
In Fedora 14 tar-1.23-8.fc14.x86_64 man page and --help optioos present the "--no-overwrite" parameter
Comment 1 Ondrej Vasik 2011-06-29 09:58:59 EDT
Thanks for report, it is not true that the option is not documented in RHEL-5 - it is documented in info documentation and I can see that option in tar --help as well ( tar --help | grep no-overwrite
      --no-overwrite-dir     preserve metadata of existing directories ). 

Man page is not maintained/generated by upstream and it was written previous Red Hat tar maintainers - so it seems they forgot to add the option to manpage - in Fedora/RHEL-6 I regenerated/extended manpage, so this (and some other options) are documented.
Comment 2 Ondrej Vasik 2011-06-29 10:03:38 EDT
Created attachment 510474 [details]
Patch adding the option into tar RHEL-5 manpage
Comment 3 Gianluca Cecchi 2011-06-29 11:06:29 EDT
ok, thanks.
Indeed I wrote "manpage" in subject, not "documentation" ;-)
And indeed you were right: "tar --help" gives the line for --no-overwrite-dir, also for tar-1.15.1-30.el5 version
Comment 8 Petr Kovar 2011-09-07 11:54:55 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the option "--no-overwrite-dir" was not documented in the tar(1) manual page. This problem has been corrected so that the option is now properly documented.
Comment 10 errata-xmlrpc 2011-11-13 22:20:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1449.html

Note You need to log in before you can comment on or make changes to this bug.