Bug 698720 - attempting to delete an operation history row actually removes the one after it
attempting to delete an operation history row actually removes the one after it
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta1
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: Ian Springer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-21 11:28 EDT by John Mazzitelli
Modified: 2013-08-05 20:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-04-21 11:28:59 EDT
I had two rows in my group operation history view - one was in status FAILURE and one was in status SUCCESS. I then submitted a group operation where one resource op failed and the other was stuck in in progress state, thus the group operation history row was also in INPROGRESS (see bug #697001 for why I was testing this)

I tried to delete the INPROGRESS group history row and it deleted the row after it instead! I tried to delete it again and it again deleted the row after it instead. In the end, while I selected the INPROGRESS row and kept hitting delete button, the result was all other rows ended up getting deleted EXCEPT the one I wanted deleted.
Comment 1 John Mazzitelli 2011-04-21 11:31:14 EDT
Side note: after deleting rows, we need to refresh the history table. So when we fix this issue, let's make sure we refresh the table too.
Comment 2 John Mazzitelli 2011-04-21 11:35:00 EDT
note: I just tested this in the resource op history view for statuses that are not in progress and the same bug happens. so this doesn't appear to be related to the status, it's just when I select a row and try to delete it, it always deletes the one after the selected row.
Comment 3 Ian Springer 2011-04-21 16:34:58 EDT
Fixed - [master 7f8c523].
Comment 4 Sunil Kondkar 2011-04-27 07:06:22 EDT
Verified on build#28 (Version: 4.0.0-SNAPSHOT Build Number: da7bcb0)

Created a compatible group of resource and executed some group operations. Navigated to the group Operations->history tab. Selected a row and clicked on 'Delete' button. The selected row gets deleted.

Verified by selecting multiple rows. Only the selected rows get deleted.
Also verified by using 'Force Delete' button.

Marking as verified.
Comment 5 Corey Welton 2011-05-23 21:14:06 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:14:08 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 7 Corey Welton 2011-05-23 21:14:09 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.