Bug 698755 - RFE: EnvironmentFile= is missing support for specifiers
Summary: RFE: EnvironmentFile= is missing support for specifiers
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 695736
TreeView+ depends on / blocked
 
Reported: 2011-04-21 17:23 UTC by Jóhann B. Guðmundsson
Modified: 2011-07-14 12:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-14 12:44:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jóhann B. Guðmundsson 2011-04-21 17:23:21 UTC
Description of problem:

Using for example 

EnvironmentFile=/etc/sysconfig/service-%i <-- Does not work 

Meaning 

Template services cant use their own environment files  

Version-Release number of selected component (if applicable):

systemd-24-1.fc15.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Create an service that uses an service template with the above mention EnvironmentFile=/path/to/file-%i
2. 
3.
  
Actual results:

systemd[1]: Failed to load environment files: No such file or directory

Expected results:

Having the ablity to allow each template service having it's own corresponding environment file

Additional info:

We are unable to port 389 Directory server to a native systemd ones until this get fixed since each service instance needs to have it's own configurable environmentfile

Comment 1 Lennart Poettering 2011-07-13 02:02:40 UTC
This is fixed in systemd git btw.

Comment 2 Lennart Poettering 2011-07-14 12:44:59 UTC
And fixed in Rawhide now too.


Note You need to log in before you can comment on or make changes to this bug.