Bug 698760 - Repositories - "Private" toggle (and possibly owner) cannot be modified after initial creation
Repositories - "Private" toggle (and possibly owner) cannot be modified after...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Content (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity unspecified (vote)
: ---
: ---
Assigned To: Lukas Krejci
Corey Welton
:
Depends On:
Blocks: rhq4 jon3-content
  Show dependency treegraph
 
Reported: 2011-04-21 13:37 EDT by Corey Welton
Modified: 2011-05-23 21:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2011-04-21 13:37:12 EDT
Description of problem:
After creating a repo, the private toggle and the owner cannot be edited via conventional means.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a new repo called "test repo".  Set enable the "Private" flag, and set the owner as some user.
2.  Navigate back to the main repo view
3.  Click the "test repo" link
4.  Attempt to edit the repo to remove the private flag or change owner, etc.

Actual results:
No repo details -- including those above or repo name, even -- can be modified.


Expected results:
User can modify repo details.

Additional info:
Comment 1 Charles Crouch 2011-04-22 09:40:19 EDT
Lukas, any impact on the scripts from alerts work?
Comment 2 Lukas Krejci 2011-04-25 04:57:02 EDT
This is a quite serious UI bug.

While the users are still able to add/remove packages in the repos, they can't edit the repo details. This is mainly important for setting the repo public/private - i.e. for sharing/not sharing the packages with other users (which was the whole point of authz changes in the content subsys).

I am sure this used to work and it looks like it is a simple UI bug.
Comment 3 Lukas Krejci 2011-04-25 11:58:00 EDT
commit 75d48dacc84f2d0020f93f6849367e267588b020
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Mon Apr 25 17:55:08 2011 +0200

    BZ 698760, BZ 698756 - polishing the repo details page.
    Edit mode wasn't functioning due to missed out parameter definitions during conversion from repo.xhtml to repo-plain.xhtml.
    The "private" toggle in edit mode wasn't working due to usage of wrong UI bean (a copy&paste bug)
    The user with repo manager privs can view any repo now even if s/he isn't an inventory manager - wrong perm check used in the UI.
Comment 4 Mike Foley 2011-05-03 10:37:27 EDT
tested RHQ 4.0 community release.  on a private repo, i could login as that user and edit/toggle the private checkbox.  As repo mgr, I could additionally change the owner.
Comment 5 Corey Welton 2011-05-23 21:17:56 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:17:57 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 7 Corey Welton 2011-05-23 21:17:57 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 8 Corey Welton 2011-05-23 21:17:58 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.