This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 698761 - systemctl status does not replace specifiers with their actual value
systemctl status does not replace specifiers with their actual value
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 13:37 EDT by Jóhann B. Guðmundsson
Modified: 2011-04-24 08:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-24 08:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-21 13:37:46 EDT
Description of problem:

When running systemctl status foo@bar.service the ouput does not replace the specier with it's value. For example ExecStart with %i in the paths 

Version-Release number of selected component (if applicable):

systemd-24-1.fc15.x86_64

How reproducible:
 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lennart Poettering 2011-04-24 08:19:32 EDT
This is actually a feature. Wildcards are only replaced at time of execution, not at reload, and we want to make that clear. That means if you use "systemctl set-environment" or edit a file specified in EnvironmentFile the changes will apply on next start of your service, not only when you reload systemd. 

If we would do wildcard expansion also on "systemctl" the output could get very confusing, since what is executed is not necessarily what we show.

So I think we shouldn't try to do this.

Note You need to log in before you can comment on or make changes to this bug.