Bug 69881 - Bad: Segmentation fault
Bad: Segmentation fault
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2002-07-25 18:53 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-25 20:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-25 18:53:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
Accidentially deleted /usr/src/linux02.4.18-5/ before removing the files inside
with "rpm -e kernel-source"
Tried to rpm -e kernel-source afterwards, and get a "segmentation fault".
I've tried rpm -e --justdb with the same results.
even rpm -ivh or -Uvh result in the same seg fault.  I've also tried rpm
--rebuilddb thinking the problem might be there.
The only thing that doesn't seg fault when dealing with that rpm file is "rpm
--verify"  that just shows all the files as "missing".

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.rm -r /usr/src/linux-2.4.18-5
2.rpm -e kernel-source

Actual Results:  Segmentation fault

Expected Results:  kernel-source rpm should have been removed from the rpm database.

Additional info:

RPM version 4.0.4
Comment 1 Jeff Johnson 2002-07-25 19:51:10 EDT
What happens if you do rpm --rebuilddb?
Please add -vv to your erase command as well.
Comment 2 Jeff Johnson 2002-07-25 19:53:26 EDT
Sorry, I overlooked that you've tried --rebuilddb.

If you give me a pointer (i.e. a URL, attachments won't work)
to a tarball of your database
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm
I'll see if I can get you a fix.
Comment 3 Need Real Name 2002-07-25 20:03:12 EDT
I did a Microsoft-standard fix..  I rebooted the server and all is well.  I
could try to do the same thing again and see if it seg faults again if you want.
Comment 4 Jeff Johnson 2002-07-26 10:00:37 EDT
No, please don't :-) But reopen the bug if the
problem reoccurs.

Note You need to log in before you can comment on or make changes to this bug.