Bug 69889 - UI tweaks
UI tweaks
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-logviewer (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-25 19:53 EDT by Havoc Pennington
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 10:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2002-07-25 19:53:35 EDT
The window title should not say "Red Hat" just "System Logs" (match the menu item).

The list on the left should not have the rules enabled, since it's a single
column, the alternating colors don't serve any purpose.

The help menu is somewhat wrong, look at gnome-terminal 
(you want Contents with shortcut F1 rather than Ctrl+H, and About, both with
stock icons)
Comment 1 Tammy Fox 2002-07-26 01:21:29 EDT
I change the window title to System Logs, changed Help to Help Contents, and
disabled rules in the list.

The default shortcut for the stock help item is Ctrl+H according to gtk-demo.
I don't have it set to anything, it just defaults to Ctrl+H. If it is supposed
to be F1, isn't that a gtk bug?

Also, gtk.STOCK_ABOUT doesn't exist. I don't see a stock icon in gtk-demo either.
What is the name for it?
Comment 2 Havoc Pennington 2002-07-26 01:41:41 EDT
It probably is a gtk bug if help is Ctrl+H, yes. Should be just "Contents"
rather than "Help Contents" (already in a menu called Help)

stock about is only in libgnomeui I guess. Don't worry about that then.
Comment 3 Tammy Fox 2002-07-29 12:44:28 EDT
It should probably just be Contents, but GNOME Terminal says Help Contents, so
I am leaving it to be consistent.
Comment 4 Tammy Fox 2002-08-02 02:02:10 EDT
On second thought, all the other apps have just Contents. I think I will
go with just Contents. 0.8-2
Comment 5 Havoc Pennington 2002-08-02 10:58:13 EDT
gnome-terminal is changed to just Contents in CVS I think.

Note You need to log in before you can comment on or make changes to this bug.