Bug 69890 - netfs retry fails to unmount NFS file systems
netfs retry fails to unmount NFS file systems
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-25 19:57 EDT by Chuck Lever
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Lever 2002-07-25 19:57:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
netfs retry either fails to unmount NFS file systems, or when it does, it fails
to recognize that it succeeded and continues retrying the umount command.  netfs
continues retrying even after the local portmap and lockd have gone away,
leaving meaningless errors on the console during shutdown.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Set up an ID with a home directory in NFS
2. log out (this leaves gconfd running in the backround)
3. immediately shut the system down
	

Actual Results:  from /var/log/messages:
Jul 21 17:46:06 dexter umount: umount2: Device or resource busy
Jul 21 17:46:06 dexter umount: umount: /home: not mounted
Jul 21 17:46:06 dexter netfs: Unmounting NFS filesystems:  failed
Jul 21 17:46:13 dexter netfs: Unmounting NFS filesystems (retry):  succeeded
Jul 21 17:46:20 dexter netfs: Unmounting NFS filesystems (retry):  succeeded

After killing all processes with TERM, netfs umount results in an
"RPC error 101" type message on the console.

Expected Results:  If retrying "succeeded" why does it retry again?
Is there a way to prevent a retry after portmap is gone?

Additional info:

umount may not update /proc/mounts on error.

Using /etc/mtab or directly parsing the output of the mount command might be a
better idea than using /proc/mounts to determine which file systems are still
mounted.
Comment 1 Chuck Lever 2002-08-01 15:16:06 EDT
Part of the problem is that retrying to unmount NFS file systems continues
after NFS statd and the portmapper have shut down.  Unmounting network
file systems needs to succeed before any network services go away, otherwise
there is no guarantee that hard mounted file systems will get all their
data written back to file servers.
Comment 2 Need Real Name 2002-11-16 12:34:35 EST
This behavior only appears with the retail version of RH 7.3. I was experiencing
the same problems on my home machines. After installing all 7.3 errata (except
kernel updates), the problem seems to have disappeared.
Comment 3 Bill Nottingham 2005-09-29 16:09:17 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.