Bug 69892 - Trying to save file in gedit crashes it
Summary: Trying to save file in gedit crashes it
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gedit (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-26 00:29 UTC by Allen A George
Modified: 2015-01-07 23:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 04:04:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gedit --debug (10.18 KB, text/plain)
2002-07-26 00:37 UTC, Allen A George
no flags Details

Description Allen A George 2002-07-26 00:29:41 UTC
Description of Problem:
I am unable to save a file in gedit since it crashes on me.  This happens no
matter which file name I choose or what text I enter.  I did not file this under
gedit however, because I suspect the problem is in the file selector itself. 
gedit runs fine until I try to save a file...

Version-Release number of selected component (if applicable):
gedit-2.0.0-1

How Reproducible:
Every time

Steps to Reproduce:
1. Start gedit
2. Type some text
3. File--->Save
4. Enter a name in the appropriate box (default is "Untitled 1"
5. Click save...app will hang

Actual Results:
The file does not save.  gedit freezes and has to be killed.

Expected Results:
The file should save properly

Additional Information:

System Specs:
P4 1.4 Ghz on Asus P4T mobo w/ 256 MB RDRAM
Asus V7100 nVidia GeForce 2
Maxtor 40GB 7200 RPM IDE HDD
Floppy Drive
HP CD-RW 9510i
Sony DVD-ROM
SBLive! Value

This is a stock RedHat install.  The only thing I've done in install aMSN and
some truetype fonts.

Comment 1 Allen A George 2002-07-26 00:34:04 UTC
PS.  Sorry I didn't mention this earlier.

I am also running GARNOME 0.12.2 on a Debian Sid box.  I have never witnessed
this problem there... Both gedit and the file selector are perfectly fine

Comment 2 Allen A George 2002-07-26 00:37:46 UTC
Created attachment 67104 [details]
gedit --debug

Comment 3 Allen A George 2002-07-26 00:41:28 UTC
Found another app with a save dialog: Mr. Project

This works perfectly there, so I conclude it is a gedit specific problem
My apologies for filing this wrong.  It won't happen again

Comment 4 Havoc Pennington 2002-07-26 01:18:38 UTC
Try gedit 2.0.1 from rawhide, it should be fixed there.

Comment 5 Jay Turner 2002-07-29 13:14:48 UTC
Fix confirmed with gedit-2.0.1-1.


Note You need to log in before you can comment on or make changes to this bug.