Bug 698924 - qcow2: Reads fail with backing file smaller than snapshot
qcow2: Reads fail with backing file smaller than snapshot
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On: 688147
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2011-04-22 06:02 EDT by juzhang
Modified: 2013-01-09 18:49 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 688147
Environment:
Last Closed: 2011-06-06 10:39:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Kevin Wolf 2011-05-03 11:23:54 EDT
This is a completely different problem than in RHEL 6. What happens is that qemu-img completely ignores the request to create a 128 MB image and just makes sn1.qcow2 the same size as base.qcow2 (i.e. 64 MB). The read fails because part of it is after the end of the image.
Comment 2 Glauber Costa 2011-05-16 14:27:44 EDT
Kevin,

What is the proposed solution for RHEL5, then ?
Comment 4 Kevin Wolf 2011-06-06 10:39:49 EDT
Not worth fixing/backporting the feature. You can't create backing files that are smaller than the disk in RHEL 5 and it looks as if nobody has ever tried in practice.

Note You need to log in before you can comment on or make changes to this bug.