Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 698978 - Slow WiFi connection on Fedora 15 with ath9k driver
Slow WiFi connection on Fedora 15 with ath9k driver
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
: 682561 699224 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 09:49 EDT by Martin Kaeser
Modified: 2011-05-03 10:55 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-02 15:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (27.41 KB, application/octet-stream)
2011-04-28 13:56 EDT, Martin Kaeser
no flags Details
nm-tool (1.39 KB, application/octet-stream)
2011-04-28 13:59 EDT, Martin Kaeser
no flags Details
iwevent (560 bytes, application/octet-stream)
2011-04-28 13:59 EDT, Martin Kaeser
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 31452 None None None Never

  None (edit)
Description Martin Kaeser 2011-04-22 09:49:01 EDT
Description of problem:
Wireless internet is compared to Windows 7 slow or almost not usable (timeouts, page not accessible)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start Fedora 15 
2. Start Chrome dev.
3.
  
Actual results:
very slow with Acer 721 one; Firefox is a little faster
almost unusable with desktop computer with wlan usb (D-Link DWA-160); connection stops and reconnects but is still slow; same result with Firefox 4


Expected results:
same speed as with Windows 7 (my internet cable dsl Upload 5000 Kbit/s, Download 50000 Kbit/s)

Additional info:
No problem with Fedora 14
Autoconnect to wlan doesn't work with Fedora 15 and the Acer 721 one

Wi-Fi Standard	IEEE 802.11 n
Comment 1 Jirka Klimes 2011-04-28 06:30:59 EDT
That is probably a driver issue. Please, report:
1. your kernel version
2. nm-tool output
3. dmesg
4. iwevent output when connecting/connected

Also look at /var/log/messages whether the connection is stable or periodically disconnects/reconnects.

Is it an issue only with 802.11n or with 802.11bg as well?
Comment 2 Martin Kaeser 2011-04-28 13:56:33 EDT
Created attachment 495619 [details]
dmesg
Comment 3 Martin Kaeser 2011-04-28 13:57:19 EDT
Comment on attachment 495619 [details]
dmesg

2.6.38.3-18.fc15.x86_64
Comment 4 Martin Kaeser 2011-04-28 13:59:13 EDT
Created attachment 495620 [details]
nm-tool
Comment 5 Martin Kaeser 2011-04-28 13:59:41 EDT
Created attachment 495621 [details]
iwevent
Comment 6 Martin Kaeser 2011-04-28 14:03:02 EDT
acer one 721 according to Windows 7: AR5B93

But Linux:
Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

06:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
	Subsystem: Foxconn International, Inc. Device [105b:e01f]
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at d0300000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 2
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [90] MSI-X: Enable- Count=1 Masked-
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
	Kernel driver in use: ath9k
	Kernel modules: ath9k

same problem with USB DWA-160: 802.11n-WLAN-Modul Realtek RTL8191SU. It is so slow that I can't use it.
Comment 7 Jirka Klimes 2011-05-02 04:52:31 EDT
It appears to be a regression in ath9k driver in kernel 2.6.38. It's been fixed in 2.6.39, I think.

You can try a workaround:
# rmmod ath9k
# modprobe ath9k nohwcrypt=1

Kernel upstream bug:
https://bugzilla.kernel.org/show_bug.cgi?id=31452

Other bugs:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/761176
https://bugs.launchpad.net/archlinux/+source/linux/+bug/735171
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622753
Comment 8 Martin Kaeser 2011-05-02 13:57:03 EDT
the workaround seems to work for the pci-express; not for the USB DWA-160 from D-Link.(In reply to comment #7)
> It appears to be a regression in ath9k driver in kernel 2.6.38. It's been fixed
> in 2.6.39, I think.
> 
> You can try a workaround:
> # rmmod ath9k
> # modprobe ath9k nohwcrypt=1
> 
> Kernel upstream bug:
> https://bugzilla.kernel.org/show_bug.cgi?id=31452
> 
> Other bugs:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/761176
> https://bugs.launchpad.net/archlinux/+source/linux/+bug/735171
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622753
Comment 9 John W. Linville 2011-05-02 14:47:10 EDT
*** Bug 699224 has been marked as a duplicate of this bug. ***
Comment 10 Neil Horman 2011-05-02 15:55:50 EDT
looks like the requested patch has already been applied to the 2.6.38-5 kernel
Comment 11 John W. Linville 2011-05-03 10:55:13 EDT
*** Bug 682561 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.